Support » Plugin: Jigoshop eCommerce » Hide out of stock items setting not respected [Potential Bug]

  • Resolved Flamekebab

    (@flamekebab)


    (Jigoshop Version 2.1)
    In the settings shopping tab the setting for “Hide out of stock items” doesn’t seem to do anything.

    I would prefer to simply hide the “add to cart” button of items that are out of stock like in 1.x but neither option works right now.

    Kind of a big deal – I don’t want customers getting frustrated because the only way to see if something is in stock is to open the full product page! (I have hundreds of products – they’d quickly leave the site…)

Viewing 5 replies - 1 through 5 (of 5 total)
  • Yep, I’ve been working on the site when it’s down for maintenance. I assumed I could see the “hidden” products (the out of stock ones) because I’m the admin.

    Checking it out now without being logged in aaaand… Yeah, the “hide out of stock” setting does nothing.

    Is it implemented solely through CSS? (I’ve disabled most of JigoShop’s built-in CSS)

    The next release will fix it 😉

    Hopefully that’ll be very soon!

    I’ve tried reapplying the setting since updating to 2.1.1 and the problem is still present.

    There’s something in the 2.1.2 changelog about this but it hasn’t fixed things that have already been migrated.

    As far as I can tell the problem is that items have the stock_status value in wp_postmeta of either 0 or 1 and the “Hide out of stock” setting relies on that.

    For some reason the migration didn’t set these values properly.

    An easy fix would be for JigoShop’s devs to create a script that looks for wp_postmeta’s stock_stock value and if it’s less than 1 sets the “stock_status” to 0…

    While you’re at it, sort out the values identified here to fix attachments.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Hide out of stock items setting not respected [Potential Bug]’ is closed to new replies.