Support » Plugin: WP Mobile Menu - The Mobile-Friendly Responsive Menu » Hide Mobile Menu on click for Anchor Links

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Rui Guerreiro

    (@takanakui)

    Hi,

    At the moment all the links I’m seeing in the right menu go to different pages than the homepage.

    https://cl.ly/3r3N1h3t1W3D

    Can you give me an example of an existing anchor Id(and in what page it exists?)

    Hello,
    Apologies, I had to change the menu to send to pages instead of anchors. I think it works better this way.
    Thanks for checking it out.
    Best
    Mitsu

    Plugin Author Rui Guerreiro

    (@takanakui)

    No problem. Let me know if necessary.

    Hello Rui,

    i have the same problem. This is the example: a simple single page with anchor links. It would be perfect if the menu disappears after a click on “Contattaci”.

    http://apple.mmn.it

    Thank you in advance.

    Stefano

    • This reply was modified 2 years, 5 months ago by stea4.
    • This reply was modified 2 years, 5 months ago by stea4.

    Hi

    I also have the same problem my site: http://xn--brnogungestrivsel-00b.dk/
    I already tried disabling all plugins 🙁

    Thanks

    Plugin Author Rui Guerreiro

    (@takanakui)

    @stea4
    Can you delete your current version and install the plugin again from the WordPress repository? don’t worry you wont lose any settings.

    @regsa94
    It seems you have a slash / in your urls, can you remove it?

    If any of you can switch the theme to Twenty 17 just for a couple minutes and check if the menu close when using Twenty 17.

    Let me know the result. This is working fine in my local development using Twenty 17.

    Thanks for the fast response.
    I have removed the / for the projekt UNIK menu link, but does not work :(. It works fine in the Twenty 17 theme, also tried removing all custom css from my divi theme, did not help, unfortunately.

    Plugin Author Rui Guerreiro

    (@takanakui)

    @regsa94 can you send me an email to [support AT wpmobilemenu DOT com] I need to ask something in private.

    Plugin Author Rui Guerreiro

    (@takanakui)

    @stea4
    This was a conflict with the Divi theme. I already made some adjustments so it can work fine.

    Replace the current file mobmenu.js located at wp-content/plugins/mobile-menu/includes/js/ by the one below.
    https://www.dropbox.com/s/mjiwhr3nx6cvy8k/mobmenu.js?dl=0

    After that clear the browser cache and test again.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Hide Mobile Menu on click for Anchor Links’ is closed to new replies.