WordPress.org

Forums

iThemes Security (formerly Better WP Security)
"Hide login area" enabled, can't log out v.4.0.2 (17 posts)

  1. UnfinishedSympathy
    Member
    Posted 1 year ago #

    Hi there,

    As many here I have problem with the option "Hide Login Area".
    Since enabled, I can't log out from wordpress, the returning url is /wp-admin.

    Server is nginx, custom .conf files updated, nginx restarted after rules changed.
    Trying to log in with another navigator (Firefox, Opera, Safari...) with the custom url: I see the login screen, but can't get in.

    If I disable the option, then I can log out and log in again...

    Any idea please ?
    Thanks

    https://wordpress.org/plugins/better-wp-security/

  2. LinkAssist
    Member
    Posted 1 year ago #

    Having the same problem. As soon as I enabled the "Hide Login Area", I was unable to log out. Disabling the feature allows me to log out again - but I'm back to using wp-login.php to login.

  3. jkd1977
    Member
    Posted 1 year ago #

    Me three. Please fix this issue since I love the ability to hide the login.

  4. Sunthing
    Member
    Posted 1 year ago #

    Same exact issue here with NGINX and not logging out.

  5. respectyoda
    Member
    Posted 1 year ago #

    I think this may have to do with your .htaccess. You will see this:

    #BEGIN BETTER WP SECURITY
    //blah
    //blah
    //blah
    #END BETTER WP SECURITY

    Delete the whole thing because .htaccess will be overwritten to by the new iThemes Security.

  6. iThemes
    Member
    Plugin Author

    Posted 1 year ago #

    Hey All,

    Most existing settings from Better WP Security transferred to iThemes Security except for the Hide Backend Setting. You’ll need to reset your Hide Backend Setting due to a new implementation of the feature. In addition, you’ll still want to review your settings after the update as there are new options you will be able to use.

    Thanks,

    Gerroald

  7. UnfinishedSympathy
    Member
    Posted 1 year ago #

    Thank you for your answer.

    What do you mean by "reset your Hide Backend Setting" ? If it means clear the option and enable it again then I already tried it (with a nginx reload for each time).
    And sorry but it doesn't work.

  8. BFR
    Member
    Posted 1 year ago #

    @UnfinishedSympathy

    http://wordpress.org/support/topic/2-issues-latest-update-login-url-disabled-funny-login-page?

    Uninstall and re-install the plugin. (That's what I did and it worked for me.) And are you seeing a weird login page like this?

    Screenshot 1
    Screenshot 2

  9. johnzenausa
    Member
    Posted 1 year ago #

    That's what my login page looks like so I disabled that feature.

  10. UnfinishedSympathy
    Member
    Posted 1 year ago #

    @Brijesh Tejani

    Thank you for your advice. I've tried to uninstall the plugin and make a fresh install again. Full of hopes when seeing there was the new 4.0.5 version.

    Unfortunatly, it didn't resolve the problem wich is still here.

    The log out link got a "302 moved temporarily" answer for two queries:
    http://www.xxxxxxxxxx.xx/secretword?action=logout&_wpnonce=a96959857e
    http://www.xxxxxxxxxx.xx/?loggedout=true

    wich it's ok because Nginx got the redirect rules

    rewrite ^secretword/?$ /wp-login.php?$query_string break;

    But then I stay on wp-admin page, still logged.

    Tried on another site I use for test, without WAF or anything that may lead to errors like this but the problem is the same.

    It was perfect with 'Better WP Security' plugin and worked flawlessly.

  11. BFR
    Member
    Posted 1 year ago #

    @johnzenausa

    I haven't disabled it yet because it helps prevent brute force attacks.

    @UnfinishedSympathy

    Oh, that is surely a bug then. Sorry I'm a beginner yet, so can't advice on what to do now. I too regret upgrading to the new version.

    I think it's time we move on to a different (and maybe better) security plugin. iThemes doesn't really care to reply to support threads. Not to mention they've four authors!

    19 out of 262 threads [resolved]

    **That represents a huge amount of dis-satisfaction.**

  12. PrincessL
    Member
    Posted 1 year ago #

    Tried all of the above with no luck. Only way I could recover control was to delete the plugin using FTP. Then install plugin from scratch. All of this is taking my time - who is going to pay me for my time?

    I will NOT be upgrading my other 31 websites until something is done about this issue.

  13. johnzenausa
    Member
    Posted 1 year ago #

    I'm upset with them because as you can see they've been bombarded with requests. I'm sure they're fixing them considering there have been several updates already. I think after a few more days (maybe a week) everything will be fine.

  14. e11world
    Member
    Posted 1 year ago #

    Same issue here but I get a blank page instead so currently will look for another plugin to just do this feature.

  15. xyzbytes
    Member
    Posted 1 year ago #

    There is still an issue here. Please fix.

  16. rosso711
    Member
    Posted 1 year ago #

    found the problem in my case at least.

    If i deactivate a specific plugin it works perfectly.

    In my case the plugin is: WooCommerce Catalog Visibility Options (Version 2.4.7)

    Please ithemes, fix compatibility with this.

  17. rosso711
    Member
    Posted 11 months ago #

    any news on this?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.