Support » Fixing WordPress » Hide "Leave a reply" Link on My Blog

Viewing 3 replies - 1 through 3 (of 3 total)
  • You would have to dig into your theme’s PHP files.
    For the WordPress Twenty Twelve theme you would have to edit content.php

    Remove or disable:

    <?php if ( comments_open() ) : ?>
    				<div class="comments-link">
    					<?php comments_popup_link( '<span class="leave-reply">' . __( 'Leave a reply', 'twentytwelve' ) . '</span>', __( '1 Reply', 'twentytwelve' ), __( '% Replies', 'twentytwelve' ) ); ?>
    				</div><!-- .comments-link -->
    			<?php endif; // comments_open() ?>

    and then in the entry-meta div remove or disable:
    <?php twentytwelve_entry_meta(); ?>

    Additionally depending on which sorts of posts you are using you might need to edit the other files starting with ‘content’ as well.

    You could also look in your index.php and see if the words Leave a Reply are in there, also anything relating to the number of replies.

    The code in my index.php is as follows <?php comments_popup_link('commenti ', '1 commento ', '% commenti '); ?>

    The word comenti would be “leave a reply” in yours.

    Always make up a backup copy of your code before deleting stuff.

    Thankyou ๐Ÿ™‚

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Hide "Leave a reply" Link on My Blog’ is closed to new replies.