Support » Plugin: Helpful » Hide Helpful if user has already voted not working if the user is not logged in.

  • Resolved Amit Bajracharya

    (@amitbajracharya)


    Hide Helpful if user has already voted not working if the user is not logged in.
    The votes get updated in the post. I can see in the post helpful metabox.

    It works really fine when I am logged in to the WordPress.

    WordPress version: 5.3.2
    Plugin Version: 4.1.3

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Pixelbart

    (@pixelbart)

    Hi @amitbajracharya,

    Did you deactivate the option “Enable to allow users to vote more than once in individual posts” in the Helpful settings under System, Miscellaneous and there also?

    I’ll have to think of something in the future so I can pull more info from Helpful to find bugs.

    Thanks for your feedback!

    Hi @pixelbart

    Yes. I have deactivated the option “Enable to allow users to vote more than once in individual posts” in the Helpful settings.
    Because I want a user to vote only once in the individual post.

    Also,
    I tried deactivating “Hide Helpful when voted” option and enabling “Already Voted” message with “Thank you!You have already voted.”
    That message is also not showing when I am not logged in. Instead it shows the helpful box again.
    Like above issue, it works well when I am logged in.

    Thank you for the reply!

    Plugin Author Pixelbart

    (@pixelbart)

    @amitbajracharya

    Did you change anything else about Helpful? Unfortunately I can’t understand the error and others don’t seem to have the problem either? The message will not be shown afterwards because the user has already voted. Actually, Helpful should not be visible anymore.

    When you vote for the first time, the message will appear afterwards. Very strange.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Hide Helpful if user has already voted not working if the user is not logged in.’ is closed to new replies.