Support » Plugin: Animated Blocks on Scroll » Hide First Stays Hidden …still

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Virgildia

    (@virgildia)

    @cyberchicken the Hide First option should be set for elements that transition to opacity 1 (100%) in CSS. Also class name ab-end is added to the animated block after an animation finishes. You can try adding to your CSS:

    .ab-end { opacity: 1 }

    If you have more animation plugins installed you may also want to check if they are using similar animation class names.

    I am working on a plugin update which will resolve this issue. A new version will be available to download in 2-3 days.

    • This reply was modified 10 months, 1 week ago by Virgildia.
    • This reply was modified 10 months, 1 week ago by Virgildia.
    Thread Starter Cyberchicken

    (@cyberchicken)

    Seemed reasonable but it doesn’t work:

    first the precedence of the selector should be higher, like
    .wp-block-ab-animate.ab-end { opacity: 1 }

    second, the opacity is not transitioned, so the block just appears out of nowhere at the end of the animation.

    Looking forward for the next iteration.

    BTW you could add a “reset” option in the scroll detection library.

    Thank you

    Plugin Author Virgildia

    (@virgildia)

    @cyberchicken thanks for your feedback! The issue seems to come from the animate.css library, as it was not initially built for scroll animations. The animation keyframes for some classes end at 50%, instead 100%. After the animation ends, the style goes back to opacity 0. I am fixing this issue in the next version and adding new features 🙂 Look out for it soon.

    For now, if you understand CSS3 animations, I recommend that you copy from animate.min.css the keyframe CSS of the animation you’re using, and in your custom CSS paste the original code and add

    100% {
       opacity: 1
    }

    at the end of the keyframe.

    Also as I mentioned, please make sure other animation plugins are not overwriting the animation classes.

    • This reply was modified 10 months, 1 week ago by Virgildia.
    • This reply was modified 10 months, 1 week ago by Virgildia.

    I’m having the same issue. The code works but flashes once before it stays. Hope to see a fix soon.

    Thread Starter Cyberchicken

    (@cyberchicken)

    I suspect the problem would go away using the updated version of animate.css
    Because there is an ancillary library for triggering animations:
    https://animate-dynamic.ga/

    Plugin Author Virgildia

    (@virgildia)

    @cyberchicken the new Animated Blocks version is available. Please ensure you delete cache before testing and you have the latest version of WordPress (5.9). The “Hide First” option was renamed to “Start with opacity 0”. Disable that option wherever you have it set (unless you’re using custom animations and it’s required). Animations that transition from 0 opacity are now set by default in the CSS keyframes to be hidden. Having “Start with opacity 0” set for them is not necessary and might cause opacity flickering.

    Old plugin versions are available to download at https://wordpress.org/plugins/carousel-block/advanced/ if you are having compatibility issues.

    If you are still seeing issues feel free to email me your website link at virgiliuweb@gmail.com as I will need to look at it in more detail. Cheers!

    • This reply was modified 10 months, 1 week ago by Virgildia.
    • This reply was modified 10 months, 1 week ago by Virgildia.
    Thread Starter Cyberchicken

    (@cyberchicken)

    Better. But I understand that opacity problems are due to the underlying animate.css library.

    You changed the block’s icon, I appreciate that.

    Thank you

    Plugin Author Virgildia

    (@virgildia)

    @cyberchicken thank you for your feedback!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Hide First Stays Hidden …still’ is closed to new replies.