Support » Theme: Hueman » Hide featured image on single page

  • Resolved ChrisSale

    (@chrissale)


    First, I have just started using the Hueman Theme and LOVE it!!! One of the best WP Themes I’ve found.

    My posts contain just an image (added with ADD MEDIA).
    And a featured image.

    This looks great in the sidebar and home page — nice display of thumbnails.

    But when I click a thumbnail to see the full post, I get both the thumbnail (from: <img class=”attachment-thumb-large wp-post-image”)
    AND my image from within the post. This looks untidy. I want to hide (not display) the thumbnail.

    I really have tried hard, but cannot find where this is being called from. Please can you point me to the .php file or function I should look at. Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi! Glad to hear.

    Two options:

    1) Don’t insert the image in the textbox as it will be automatically included anyway (the thumbnail)
    2) Select “Standard” format post instead of “Image” and you will instead disable the thumbnail above, and show only the inserted image.

    <gasp> It cannot be that easy!!?
    Tried it. It works. THANK YOU.

    With method 2 I can use different pic for thumbnail to inserted image(s).

    Now I must go and remove all the Commented Out lines in all those .php files that had no effect at all!!?? ie. <?php the_post_thumbnail()

    Just for education, could you tell me WHERE the thumbnail is called? It must be somewhere I did not find. (ignore this if you are busy).

    🙂

    In single.php it’s called with:

    <?php if( get_post_format() ) { get_template_part('inc/post-formats'); } ?>

    So it’s within /inc/post-formats.php, below where it says:

    <?php if ( has_post_format( 'image' ) ): // Image ?>

    Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Hide featured image on single page’ is closed to new replies.