Support » Plugin: A-Z Listing » hide-empty-terms not working

  • Hello! I have problems with “hide empty terms”.

    I have this shortcode on my website:

    [a-z-listing display=”terms” taxonomy=”autor” hide-empty-terms=”true” cols=”3″]

    It used to work but not it’s not working and my site is showing all empty taxonomys.

    I also tried change yes for “1”, “on”, “yes” and nothing works.

    Does this plugin need an update?

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Dani Llewellyn

    (@diddledani)

    Hi,

    Thanks for the topic, it does sound like I’ve broken it in version 4.0.0+ 🙂

    I’ll try to find out what’s up and release an update with a fix when I work out what I broke.

    Sounds like the same problem I mentioned in my question “Exclude a specific category” from a week ago…. 🙂

    Thread Starter tnc05

    (@tnc05)

    Yeah, I think you’re right @diddledani !

    Do you know when you will fix it? So so, just to have an idea because I really need it and in case it takes to long I need to deactive plugin temporary.

    Thanks!

    Plugin Author Dani Llewellyn

    (@diddledani)

    Hi,

    I haven’t found the problem yet, but I notice in your original post your quote characters are not the usual " but are special quotes . Can I ask that you double check which quotes are in your shortcode please, because the special ones will break the matching of the value. You could try, as the parameter is a single word with no spaces, eliminating the quotes altogether to be sure the type of quote isn’t an issue:

    [a-z-listing ... hide-empty-terms=true]
    
    Thread Starter tnc05

    (@tnc05)

    Hello! I am using “, not ”. It turns on special one when I paste it in here, on this post.

    Check my original shortcode: https://gyazo.com/3ef38e7cb4685a74201bf1b1d4e3bafa

    I’ve tried on differents ways but it doesn’t work :/

    Plugin Author Dani Llewellyn

    (@diddledani)

    Thanks for the update. I’ll keep digging 🙂

    xysum

    (@xysum)

    Hi!

    Any progress on this? Would love to hide those empty terms.

    Great plugin overall!

    Thread Starter tnc05

    (@tnc05)

    Hello! Any news? :/

    Plugin Author Dani Llewellyn

    (@diddledani)

    Hi,

    This should have been fixed with version 4.2.1. However, if it is still broken after updating, you can try using the older (no-longer supported) attribute of hide-empty=true, which is still present for backwards compatibility purposes.

    Plugin Author Dani Llewellyn

    (@diddledani)

    Oh, I see I failed to release the plugin properly for version 4.2.1. I’ll re-roll the release now!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘hide-empty-terms not working’ is closed to new replies.