Support » Plugin: WooCommerce » Hide empty categories in widget

  • Resolved alinden

    (@alinden)


    Hello,

    In the product category widget I selected “Hide empty categories”. But still categories with products in “draft” are shown. How can I hide the categories with only products in draft as well?

    Kind regards, Aron.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Do they show if you visit your site not as admin (anonymous tab, another browser etc)?

    Thread Starter alinden

    (@alinden)

    Yes they do. You also see the amount of (draft) products behind the category name. And when you select that category, it shows “No products were found matching your selection.”.

    btw I use the storefront Theme with Boutique child theme. But the problem is also on other themes.

    Can’t reproduce that behavior, WC 3.2.1. If the products are Draft, the category is not shown. Tried with parent and child categories. We are talking about “Product Categories” widget, right?

    May be give some steps to reproduce or exact settings and setup.

    Thread Starter alinden

    (@alinden)

    I found out the problem / solution:
    I imported the products with WP ALL Import and the draft products where set on draft. I now selected all the draft products in the backend and bulk edited them to set draft again. That worked!

    Thanks for your help and kind regards, Aron.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Hide empty categories in widget’ is closed to new replies.