Support » Plugin: Challonge » Hide bracket when not started

  • Hi,

    I noticed you said it will be added a function to hide the bracket until the tournament is started.

    I want to see the participant, but not placed in a bracket.
    Is this possible? The problem is that some of the teams might think it’s good to go and start playing their matches once they see their team in the bracket.

    Is it possible to hide the bracket until I start the tournament?
    Or maybe only showing the signed up teams (not in a bracket) until I start the tournament.

    Best regards.

    https://wordpress.org/plugins/challonge/

Viewing 10 replies - 1 through 10 (of 10 total)
  • And also, is it possible to show when the tournament starts? Instead of when it’s created.

    And one more question (sorry about this).
    Is it possible to make all teams to be placed in a waitinglist when signing up?

    I want the posibility to choose if a team is accepted or not.
    If I’m hosting a tournament for 16 teams, I want it to be able for endless amount of team to sign up but I want the ability to choose the 16 teams that will be accepted to participate.

    Is this possible?

    Plugin Author zavaboy

    (@zavaboy)

    Sorry for the delayed response.

    I want to see the participant, but not placed in a bracket.
    Is this possible?

    This is not currently possible. I will consider solutions.

    And also, is it possible to show when the tournament starts? Instead of when it’s created.

    It should already be doing this. Please be sure you are using the latest version. (Perhaps I misunderstood?)

    Is it possible to make all teams to be placed in a waitinglist when signing up?

    This is not possible. One suggestion is to inform your teams that signup doesn’t guarantee participation and manually remove the teams you have not accepted before the tournament begins.

    I, unfortunately, can not meet everyone’s needs with this plugin. Thank you for your feedback though! It really is appreciated. 🙂

    Hi again,

    Thanks for the response!
    If you take a look at: http://supahstar.se/tournaments/ You can see that it’s showing “Created on” instead for starting time.

    I’m using Version 1.1.5.

    Plugin Author zavaboy

    (@zavaboy)

    A new “Display” setting was added in 1.1.5. You may toggle on “Start At” to display the scheduled start time or “Started At” to display the actual start time in the tournament listing table.

    (Sorry I didn’t update the settings screenshot to reflect this change.)

    Of course, let me know if you have any difficulties.

    Hi again,

    Where do I find these settings?
    Do I change the Alias on “Created on”?

    Have a look at my settings in this screenshot:
    http://www.ladda-upp.com/bilder-a/dfsadfsa-662.jpg

    I can only see the following display-choises:
    – Name
    – Type
    – Participants
    – Created at
    – Progress

    Thnx in advance

    Plugin Author zavaboy

    (@zavaboy)

    Oh noes! >_<

    It looks like I messed up! There’s supposed to be more items in that list.

    I will have to get back to you later on steps to fix it.

    Sorry about this.

    Edit:
    You should really change your API key now that anyone can see it.
    Also, 2 questions:

    1. What browser are you using?
    2. Did you update from a previous version of the plugin or is this a new install of it?

    Thanks!

    Hi again,

    Yeah will renew the API!
    It’s a new install of the plugin.

    Also, if I hide one of the items I cant get it back!

    Thnx

    Plugin Author zavaboy

    (@zavaboy)

    I suspect there is a conflict in CSS class names between the Challonge plugin and another one you have installed. It’s not really the fault of the other plugin. I should have made my class names more unique.

    I’m unfortunately tied for time for most of this month, so I may be unable to release a fix anytime soon.

    You have (basically) 2 options until I get a fix made:

    • Manually show all items then hide the ones you don’t want.
      1. Open developer tools (eg. Ctrl+Shift+I in Google Chrome) while on the Challonge Settings page.
      2. Press Ctrl+F to do a search.
      3. Search for: ui-state-default hide
      4. For every found result, double click the highlighted result to edit it.
      5. Change the word “hide” to “show”.
      6. Once you have done this for all results, you should see all items in the list.
      7. Hide the ones you don’t want to show.
      8. Save the settings.
    • Find and disable the conflicting plugin temporarily.
      1. Deactivate one plugin, maybe one you may think could cause it.
      2. Go to Challonge Settings page.
      3. If you still do not see the “hidden” items, reactivate the plugin you deactivated and start from step 1 again with a different plugin.
      4. If you can see the “hidden” items, make your changes and save the settings.
      5. Reactivate the plugin you deactivated.

    I hope this helps you! Let me know if you have any troubles.

    Hi again!

    Thanks alot for your reply.
    Managed to figure it out. The class “hide” was already in another plugin using “display:none;”. So I got it all figured out!

    Thnx alot!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Hide bracket when not started’ is closed to new replies.