Support » Plugin: iThemes Security (formerly Better WP Security) » Hide backend with site in subdirectory unusable

  • Once I enable the ‘Hide Backend’ feature I am no longer able to login. It keeps sending me back to the login page. I have to disable the feature again through phpMyAdmin before I can get access to the Dashboard again.

    As I say in the title the site is installed in a sub-directory but is accessed without that dir appearing in the URL

    ie wp install is in http://www.<mysite&gt;.com/subdir/ but access is at http://www.<mysite&gt;.com/ and that was done the standard way through settings page in the WP install and also copying the index.php file into the root directory and adding the subdir in there.

    https://wordpress.org/plugins/better-wp-security/

Viewing 5 replies - 1 through 5 (of 5 total)
  • I notice the same issue with the latest version. Hope it can be fixed soon!

    I also had this problem.

    The problem, as I see it, is that only the .htaccess in the subdirectory gets updates. The .htaccess in the root still has the old redirects from WP security!!
    To login again I had to delete the .htaccess in the subdirectory, and then my site is working again and I can login. Only the .htaccess will be regerated when you save a setting in iTeams security.

    This should be fixed soon, or I’d better go install an old WP securtiy plugin :/

    Nobody of iThemes with a reply??

    This seems to be working for me now.

    using a subdir wp-install on a nginx server and the hide backend does not work.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Hide backend with site in subdirectory unusable’ is closed to new replies.