Support » Plugin: iThemes Security (formerly Better WP Security) » Hide backend not working

  • Hi,
    i have a staging site (created from WP time capsule) and i tried to enable Hide Backend login site to a different name.

    However, when i go to the new URL of my login page, it returns a 404.

    Is there something wrong?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Did you allowed the plugin to write .htaccess file? … In global settings
    I have

    • This reply was modified 2 years, 8 months ago by shalke04.
    Thread Starter dreamzspl

    (@dreamzspl)

    Hi,
    i have..

    I am using nginx server so there is rewrite on nginx.conf instead.

    Can anyone help?

    As of the 6.3.0 release the iTSec plugin Hide Backend feature does not write to the .htaccess or nginx.conf conf files. Any present rewrite rules in the nginx.conf (or .htaccess) file are the result of other iTSec plugin features.

    When you enable the Hide Backend module an email notification is send to the site admin(s). Check the email and make sure you are using the correct login slug.

    Hi all, seems i have an issue similare here:
    when i activate the hidden backend module, it does not activate my new admin adress…

    I am using nginx and it is a fresh install.
    I checked file rights and ithemes sec can write the nginx.conf
    Tryied a lots of solutions but found no true solution/advices on the web.
    So to be clear:when i try my new admin adress https://mysite/mynewadmin for exemple i have an error 404. BUT i can log in with the https://mysite/wp-login.php so it seems that nothing happened.

    I test a nginx specific directive in the server:

    if (!-e $request_filename) {
    set $test P;
    }
    if ($uri !~ ^/(plesk-stat|webstat|webstat-ssl|ftpstat|anon_ftpstat|awstats-icon|internal-nginx-static-location)) {
    set $test "${test}C";
    }
    if ($test = PC) {
    rewrite ^/(.*)$ /index.php?$1;
    }

    and it made my new adress working…but also /wp-login.php and /admin! (as the normal hidden module activated should exclude /wp-login.php and /admin)

    Any help here to understand?
    Thx a lot!

    • This reply was modified 2 years, 6 months ago by KaizenLab.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Hide backend not working’ is closed to new replies.