Support » Plugin: iThemes Security (formerly Better WP Security) » Hide admin and wordpres https

  • The hide admin option doesn’t work when using the wordpress https plugin. Here’s a few notes.

    Using the ithemes inbuilt ssl doesn’t work as expected, breaking some content that is not delivered securely (within the theme) the HTTPS plugin is required because it converts that content (like some background images and javascript) to be delivered securely and to work properly.

    Everything works fine except the hide backend feature. As soon as that is enabled I am redirected to the the 404 everytime I try to reach the dashboard. I am still logged in, as I can see the admin bar, but trying to get to the backed takes me to the not_found page created by ITSEC

    Enabling the “Any page that is not secured via Force SSL or URL Filters will be redirected to HTTP.” in HTTPS causes a redirection loop – so I have this turned off

    When hide backend is switched on i am not logged out automatically as I would expect without https. I can still log out and in at the new url (eg https://mysite.com/mylogin) – its the dashboard I can’t access

    I have set have tried both ways to force all pages to redirect to htps – by adding a / in the URL filters in https
    – by setting the ITSEC SSL options to whole site
    and all combinations thereof – I can’t access the dashboard with any combination

    I have disabled https and used ITSEC options exlusively and my site doesn’t work (javascript doesn’t load). It all worked fine before changing to https.

    General site URL is set to https

    My SSL is delivered flexibly through cloudflare, i have enabled the cloudflare extension in ITSEC

    Hopefully this should give you enough info to troubleshoot the problem

    thanks

    https://wordpress.org/plugins/better-wp-security/

  • The topic ‘Hide admin and wordpres https’ is closed to new replies.