Support » Plugin: Jetpack by WordPress.com » Hi Jetpack! All Systems go

  • Resolved Marc Kranat

    (@marclouis)



    Not really a support request, but I have seen this come up a few times, google did not help here.

    CDNs and proxy firewalls showing “Hi Jetpack! All Systems go”, some do not have JetPack plugin itself installed, or have it, removed it, and it still does not get rid of this page showing on their home page.

    I found on the most recent one, no Jetpack enabled:

    192.0.102.40 16/Oct/2017:12:58:40 NOT BLOCKED HEAD 200 / CACHEP:HIT –
    jetmon/1.0 (Jetpack Site Uptime Monitor by WordPress.com)

    every 3 mins of so, as soon as I blocked that UA, cleared the cache, “Hi Jetpack! All Systems go” never returned. very odd as JP was not installed, but that was what was causing it, tested on another 2 showing the same symptoms, also resolved.

    maybe adding a variable (domain.com?dateandtime) here to the monitor request would fix that, it would also bust the cache so let you know if the site was really up rather than looking at a cached version on cdn.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    That User Agent is indeed the one used by our Monitoring Agent, but I’m not sure I understand the role it plays in this case. Does that “Hi Jetpack! All Systems go” message appear in your logs, or on the site itself? Is it the only thing appearing on the page?

    Do you think that message appears on the page whenever it is visited by our monitoring agent? If so, do you think your CDN or firewall bypasses Jetpack Monitor and outputs a success message regardless of what’s actually on the site?

    Marc Kranat

    (@marclouis)

    odd as they are head requests, there is no other data. immediately following that monitor visit, the site (well homepage) shows as just that one line on an empty page, not cached by the site itself, but in this case the Sucuri firewalls cache, I have seen cases of multiple hosts and CDNs also caching this. I tested with all plugins disabled, including JetPack, only comes after that monitor visit is recorded in logs,

    # curl https://removed[.]com

    Hi Jetpack! All systems go.

    # curl -I https://removed[.]com
    HTTP/1.1 200 jetpackok
    Server: nginx
    Date: Sun, 15 Oct 2017 02:38:13 GMT
    Content-Length: 30
    Connection: keep-alive
    Age: 0
    X-Cache: uncached
    X-Cache-Hit: MISS
    X-Backend: all_requests
    Via: http/1.1 removed[.]prod.phx3.secureserver.net (ApacheTrafficServer/5.3.2 [c sSf ])
    X-Sucuri-Cache: HIT
    X-XSS-Protection: 1; mode=block
    X-Frame-Options: SAMEORIGIN
    X-Content-Type-Options: nosniff
    X-Sucuri-ID: 14008
    Accept-Ranges: bytes

    All odd as I can’t find that text in the plugins code, and this is just a head request, blocking your UA is not very elegant a fix, maybe you can find something better.

    Plugin Contributor George Stephanis

    (@georgestephanis)

    I wonder if this is some sort of optimization that your host has put in place to short circuit Jetpack Monitor requests to your site — responding to the monitoring agent with “Hi Jetpack! All systems go.” instead of letting it trigger WordPress as it should — and then the response gets cached by CloudFlare or the like and served up to regular users.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    Jetpack Monitor does indeed only make HEAD requests, since it doesn’t need the date that’s on the page.

    All odd as I canโ€™t find that text in the plugins code

    Jetpack does not include that text anywhere. All what Jetpack Monitor does is a HEAD request, it does not need to include any text on your site to verify that it it up.

    I suspect this is an unfortunate consequence of the different tools you use on your site.

    I think your firewall might include a rule that catches all Jetpack Monitor requests (either by looking at the IP, or at the User Agent), and serves a custom response to the monitoring agent, with the body “Hi Jetpack! All systems go.” This tricks our Agent into thinking that your site is always up, making the agent completely useless. Could you try disabling your firewall or reaching out to your hosting provider and ask them if they have such a rule in place?
    If that’s really happening, you can just disable the Monitor feature from your site. You can do so here:
    https://wordpress.com/settings/security/
    Once you’ve done so, please let me know the name of your firewall or host; I would then reach out to them and see if we can work together to remove that rule from their system and thus have Jetpack monitor the site itself, not a special response set up by the firewall.

    In addition to this, it is possible that your host or your caching system caches the firewall response and then serves it to regular visitors. That would not be a problem if the first problem was solved (since the response the monitoring agent would get would be the same as the visitors), but in this case it is a problem. You would consequently have to make sure Monitor responses are never cached in your system.

    Could you run some tests and let me know what you find?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    Oops, I’m just seeing now that George jumped in as well. I’m glad to see we are drawing the same conclusions ๐Ÿ™‚

    Marc Kranat

    (@marclouis)

    Yes @jeremy, I have him in email so we can discuss specifics, at least we know what the trigger is now, but where’s the message coming from that’s populating the cache?

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    whereโ€™s the message coming from thatโ€™s populating the cache?

    It may come from your firewall, or from your hosting provider. It does come from something sitting in front of your site, catching all visits from our monitoring agent, and sending it that custom message.

    Since I don’t know much about your site setup I can’t tell you much more, but if you’ve been chatting with George via email I’d encourage you to continue the conversation with him there, so we can figure this out.

    My site americancranenh.com is also sending out the dreaded “Hi Jetpack! All systems go” message. Did any of you find a fix for it? Can you help me out? I created this site brand new two weeks ago for my new employers and it doesn’t look good for me that it isn’t working!!! Any help would be greatly appreciated! Thanks! Beth ๐Ÿ™‚

    I host on Godaddy.

    Hi @evansline9,

    Sorry, the only solution where disabling the monitoring initially did not work, or was not possible, which triggers the request that to can be cached, is to block the jetmon ua of the request using the firewall or something in the .htaccess.

    Plugin Contributor George Stephanis

    (@georgestephanis)

    Howdy, @evansline9 && @marclouis!

    I’ve confirmed with some folks that the “dreaded Hi Jetpack! All systems go.” message is indeed being generated from GoDaddy’s systems in response to Jetpack’s Uptime Monitor checking in to make sure your site is still running.

    Unfortunately unless they change their system overrides, there isn’t much that can be done short of disabling monitoring (which really shouldn’t be necessary, but that’s the situation they’ve put our mutual users in), disabling caching via whatever system or Cloud Proxy you may be using, or switching hosting (which also shouldn’t be necessary, but it is GoDaddy’s code that is explicitly causing the issue).

    If a user wants uptime monitoring, in my opinion your host shouldn’t decide to short circuit that decision, or respond automatically “all good” regardless of the site’s actual status. Some folks use the Uptime Monitor’s ping every five minutes to make sure their site’s Cron jobs run regularly — and this prevents that from happening.

    I wish I had better news for you — we’re in contact with some of their techs and hoping they’ll get the issues rectified, but that’s the current status quo.

    Cheers,
    George Stephanis
    Jetpack Jedi Archivist

    I’m having this problem now on a site I visit.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    @nld3 I would recommend that you contact the site owner to let them know about the issue.

    You can point them to this thread if they need more info about the problem. They should then be able to contact their hosting provider, Godaddy, to report the issue to them.

    @jeherve, I did. Thanks

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    @everyone

    I wanted to follow up with all of you regarding this issue.

    Up until yesterday, GoDaddy would return a custom response to all requests coming from our monitoring service, notifying our service that your site was up and publicly available, even when that wasn’t the case. This was therefore making Jetpack’s Monitoring service fairly useless on your site, and it was sometimes causing issues due to GoDaddy’s server caching configuration; some of your readers would sometimes get the response our monitoring service was getting (Hi Jetpack! All Systems Go.) instead of seeing your site.

    This is now resolved. We had notified GoDaddy about the problem, and they just let us know the problem was now resolved; that caching issue won’t happen now. Your readers won’t see that custom response Jetpack Monitor gets. Jetpack’s Monitor service will continue to see that response though, so it may not reflect the actual status of your site. For this reason, you can probably deactivate the feature as it won’t give you any 100% reliable results.

    If you have any remaining questions about all this, don’t hesitate to contact us!

    isimission

    (@isimission)

    I posted on Saturday under a different link, and the only reply was from someone who thought I might be getting unwanted emails from JetPack, which I’m not receiving.

    After reading this link, it seems that maybe one of you can give me good advice or help me?

    Here’s the issue: Iโ€™ve uninstalled JetPack and Iโ€™m trying to turn off monitoring for this domain iServants.com. I think Iโ€™ve disabled it but it is still be coming up with an error message randomly that says โ€œhi jetpack! all systems goโ€. About 20% of people who try to access our site cannot do so because they instead just get a blank page with the words “hi jetpack! all systems go”.

    To replicate what I’m referring to, try going to Pingdom.com and putting in our website iServants.com and choosing “new york” as the location to search from.

    Our website was built by GoDaddy but GoDaddy hasn’t been able to fix the problem, even though they see the same issue randomly showing up in their own screen shots of our website and/or on sites like Pingdom.

    Can you fix this for me? Or tell me how to fix it? Thanks!

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.