Support » Fixing WordPress » Can’t access to my admin page

  • Resolved nadstation

    (@nadstation)


    I hope you are all fine!

    I am experiencing an issue with WordPress.
    I can’t access to my admin anymore.

    https://www.example.com/wp-admin

    or

    https://www.example.com/wp-admin/index.php

    It redirects me to :

    https://www.example.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.example.com%2Fwp-admin%2Findex.php&reauth=1

    Here my configuration:

    Scaleway server wordpress instant app
    nginx version: nginx/1.10.3 (Ubuntu)
    Distributor ID:	Ubuntu
    Description:	Ubuntu 16.04.4 LTS
    Release:	16.04
    Codename:	xenial
    Scaleway wordpress instantapps
    Wordpress version: $wp_version = '5.2.1';

    I tried to rename the “plugins” folder to “plugins-disabled” in order to deactivate all the plugins, clear browsing data ( Cache … ), I tried on different Browser ( Safari and Chrome ) and I changed the theme.
    I checked the database field siteurl and home on the table wp_options.
    I see https://www.example.com which is ok to me .

    Here my NGINX configuration file:

    server {
    listen 80 default_server;
    
    server_name example.com;
    return 301 https://$server_name$request_uri;
    }
    
    server {
    listen 443;
    ssl on;
    ssl_certificate /etc/ssl/cert.crt;
    ssl_certificate_key /etc/ssl/mykey.key;
    
    access_log /var/log/nginx/nginx.vhost.access.log;
    error_log /var/log/nginx/nginx.vhost.error.log;
    
    include snippets/phpmyadmin.conf;
    
      client_max_body_size 200M;
    
      root /var/www;
      index index.php index.html index.htm;
    
      location / {
              try_files $uri $uri/ /index.php?q=$uri&$args;
      }
    
      error_page 404 /404.html;
    
      error_page 500 502 503 504 /50x.html;
      location = /50x.html {
              root /usr/share/nginx/html;
      }
    
      location ~ \.php$ {
              try_files $uri =404;
              fastcgi_split_path_info ^(.+\.php)(/.+)$;
              fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
              fastcgi_index index.php;
              include fastcgi_params;
              fastcgi_param  SCRIPT_FILENAME    $document_root$fastcgi_script_name;
      }
    
    }

    It should not redirect me to the login page.

    Do you have an idea where does it come from ?
    It would be great if somebody can help me

    Thank you in advance.

    • This topic was modified 5 months, 4 weeks ago by nadstation.
    • This topic was modified 5 months, 4 weeks ago by nadstation.
    • This topic was modified 5 months, 4 weeks ago by nadstation.
    • This topic was modified 5 months, 4 weeks ago by Steve Stern.
Viewing 6 replies - 1 through 6 (of 6 total)
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.