Support » Plugin: SumUp Payment Gateway For WooCommerce » Here’s how to set it up in 5mins

  • The official documentation lacks precise information on how to set this up. Especially for non-technically minded persons. So, long story short, I assume you already have created a SumUp account:

    1. Login to your SumUp account
    2. Go to the developer settings in your account
    3. Scroll down to the bottom, where it says “OAuth …”
    4. Generate new credentials
    5. Choose app-type “Web”
    6. Enter anything for client name (I entered the name of my shop). It’s just a reference for you.
    7. As callback URL enter the URL to which the user should be redirected after the payment with SumUP has been processed. This is likely your shop’s URL. It’s not an API callback URL, but a simple redirect.
    8. The Authorized JavaScript Origin should be set to your shop’s homepage, in order to add a little more security.
    9. Click the Save button.
    10. The new client ID is shown in the OAuth section.
    11. Copy and paste the client ID to the appropriate field in the plugin configuration.
    12. To get the client secret, download the JSON file and open it with the simple text-editor like Notepad or similar.
    13. In the JSON you find something like “client_secret”:”cc_sk_classic_…”
    14. The part between the quotes starting with “cc_sk_classic_” or similar is your client secret.
    15. Copy and paste the client secret in the appropriate field in the plugins configuration.
    16. Enter the e-mail address of your SumUp account into the field “login e-mail”
    17. Save your settings.

    That’s all you need to do. Have fun!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You are an absolute hero my friend.

    The developers set up everything without even giving the users a guide on how to set it up, I am so glad that i found this.

    Let me know your PP and i will send you some money

    Thread Starter acidstout

    (@acidstout)

    Thanks for your offer, but I don’t need any money. If you really want to pay tribute, you are free to donate some BTC to this address: 0x160443c73f5fb9cdeace14ec5cb431fd51f68ed5 on BNB Smart Chain (BEP20). All donations will be used to support Ukrainian refugees.

    Hey there! I have troubles when I insert the Sumup keys etc.
    When I click on the save button, I get : “Warning: Cannot modify header information – headers already sent by…” errors. Any idea how to fix this? Thank you for your precious help…

    Thread Starter acidstout

    (@acidstout)

    Hi! The warning message “Cannot modify header information …” is very likely caused by another plugin and/or your web server’s configuration. As a first approach I would try to disable all other plugins, and then try to set up the SumUp plugin. Once set up, re-enable all previously disabled plugins. If that doesn’t work, you may try to switch to the default WordPress theme in case you use a custom theme. If nothing helps, you need to modify your web server’s configuration (likely its php.ini file). Your web hoster should allow you to do this in one or another way. The setting in the php.ini you want to change is called “output_buffering”. Its default value is 4096, and you want to set it to “On”. That should prevent the warning message in nearly all cases, and allow you to save the settings in the SumUp plugin.

    Thank you so much for your help… that is amazing! So, I have tried to unable all plugins (except Woocommerce and Sumup of course), and change theme, but I still have the problem. I haven’t mentioned that I am using Elementor and Elementor pro (which I both disabled for test purposes), and that everything has been built through that.

    I opened the three files the errors notify and the concerned lines. Here they are :

    In the wp-admin/includes/misc.php file :
    header( sprintf( 'Referrer-Policy: %s', $policy ) );

    In the wp-includes/functions.php file :
    header( 'X-Frame-Options: SAMEORIGIN' );

    In the wp-admin//admin-header.php file :
    header( 'Content-Type: ' . get_option( 'html_type' ) . '; charset=' . get_option( 'blog_charset' ) );

    I have never changed the php.ini file, but I can call the host for guidance, if this is the only way through.

    Do you have any idea of what could be happening with the lines cited above?

    Thank you so much for your help.

    PS / When I save, it also says that my keys are valid, and in the checkout, I do see the card option, bu when I click on “Order”, litterally nothing happens…

    Thread Starter acidstout

    (@acidstout)

    The quoted header() instructions basically send information to the browser on how to process. For example the “X-Frame-Options” parameter set to “SAMEORIGIN” tells the browser that the website sending this header is not allowed to be run embedded in an iframe of another website.

    So, basically it is safe to temporary comment these lines out by putting double-slashes “//” at their beginning. However, that does not solve the issue on the long run, and all three files are core files of WordPress and should not be modified. At least following the next update they will get overwritten anyway.

    I really suggest you to contact your web hoster and tell him to modify the php.ini file for you as stated in my previous post. Again, this is just a suggestion. I cannot know if this really fixes the issue, since I basically don’t know anything about the setup of the web server etc.

    Regarding the missing card option I have absolutely no clue what’s wrong. Maybe it is some payment setting in WooCommerce itself or in the SumUp plugin. I can’t remember how I configured it (it was long before I wrote this setup guide).

    Thank you! Simple but crucial question : are these lines errors stopping the plugin from working properly, or can they just be ignored?

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this review.