here's a wierdie - 3.0.1 subdomain MS knocks out mail servers (6 posts)

  1. gazouteast
    Posted 5 years ago #

    Before I start, I'm assuming this is caused by poor ordering of the server aliases in httpd.conf and vhosts.conf ,, but could be wrong

    History - working WPMU upgraded to 3.0 MS during site development (ongoing) then upgraded to 3.0.1 a few days ago. Currently main blog and child-blog for developing parent and child theme that will be used when the site goes live.

    Under 2.9.2 with the wildcard subdomains set on server and in DNS, I know the mail servers and webmail mailboxes worked and were accessible, never checked them during the 3-4 weeks 3.0 was running, but after 3.0.1 I had cause to go check a test mail had been received after adding a plugin today (Sitewide Newsletters plugin).

    None of the mailboxes were available - they all just returned http:500 or 404 errors. trying to browse direct to webmail.domain.com as per hosts help didn't yield the webmail login splash, it just dumped me back at site home with a message I was already logged in and sub-blog webmail did not exist.

    Trying a dumbcluck back-end workaround like browsing to webmail.wp30domain.hostingaccountdomain.tld just dumps me at the search engine "page not found" default (as expected).

    Have got the hosting techs looking into this but wanted to share it with everyone in case anyone else hits this issue - my suspicion is that the *.domain.tld in http.conf or vhosts.conf is too high in the list for the domain, and that it's knocking out the fixed-name subdomains for the mail servers - pop3.domain.tld, smtp.domain.tld and so on, because its just reading the wildcard and handing over to htaccess and thus WP, rather than resolving to the correct A records from DNS.

    Anyone think it might be something different?

  2. gazouteast
    Posted 5 years ago #

    Forgot to mention - this is Plesk 9 on Unix

    The hosts support team have put a ticket in to Plesk on this, but hoping someone here has some clues about it.

  3. Yep, it's in the wrong order.

    If the wildcard line was put in the vhosts.conf file, then the other records should come before that.

  4. And your mail stuff is all DNS related (for direction) so they mucked up that somehow too. mail doesn't come in via httpd.

    Like I sad in the other thread, find a webhost that knows what they're doing.

  5. gazouteast
    Posted 5 years ago #

    We've now tried every possible order combination, including rolling dice to see where to put them (I kid you not) and the problem has persisted throughout.

    Logically, I am in 100% agreement with your assessment about the ordering - to me it absolutely has to be that, except the hosts have tested and tested, and no change to the order has resulted in a working solution.

    As to a web host who knows what they're doing - that's a cheap shot Andrea, and not something I'd normally expect from you when talking about the UK's largest cloud hosting service, especially as you've been told more than once that even the techs from Parallel (Plesk) themselves, cannot figure this out.

    Still looking for a solution but may end up appealing for one of them funny jackets that fasten at the back before this gets resolved.

  6. gazouteast
    Posted 5 years ago #

    Quote me in 1st post

    I know the mail servers and webmail mailboxes worked and were accessible

    Quote Andrea

    And your mail stuff is all DNS related (for direction) so they mucked up that somehow too. mail doesn't come in via httpd.

    Webmail absolutely does get accessed via httpd - the webmail (Horde, RoundCube, SquirrelMail, AtMail etc) are all configured in /etc/httpd/conf.d/

    The solution finally revealed =
    How to use WordPress Wildcard Subdomains on Plesk 9.x Hosting -
    How to retain webmail access with wildcard subdomains when using Plesk Panel
    which also confirms the effect of httpd on using WEBmail clients.


Topic Closed

This topic has been closed to new replies.

About this Topic