Support » Plugins and Hacks » [Resolved] [W3 Total Cache] Have the same problems with broken CSS & more

[Resolved] [W3 Total Cache] Have the same problems with broken CSS & more

  • first a big ty for this superb plugin!

    just this current version HAS some problems (with all mayor browsers) – rendering errors can also be seen with webpagetest:

    – broken css & js when minify is on
    — auto setting not working
    — manual (verbatim copied from last w3-cache) also dead

    – no gzip on all css, js files

    – compatibility check output has transparent background garbeling text

    – Google Page Speed dashboard widget setting doesnt toggle

    – i get no minify error notification, even when i have 404 on css & js files

    hope it all gets fixed soon.

Viewing 15 replies - 1 through 15 (of 21 total)
  • I’ve exact same problem after updating W3 Total Cache to latest version.Any way to fix this?

    Ack. Me Too!. My previous minify settings were working great before upgrade. Hope this gets fixed soon, it’s a great plugin.

    +1, same issue for me.

    i guess by now our dear plugin author knows that something went wrong! some many changes in the current version of this complex plugin..

    just found out when it gives me the 404 file-not-found for minified js and css files these are looked for in the wrong directory stemming from site root. but in my WP installation actually resides in a subdirectory.

    http://zzz.org/wp-content/w3tc/min/0fb4a/default.include-body.2138336412.js (whole path not existing)

    http://zzz.org/SUB/wp-content/w3tc/min/0fb4a/default.include-body.2138336412.js (like this, it worked in the last version)

    this line in the changelog makes me think
    “Moved browser cache rules to site root instead of document root”

    anyway i can wait a few days with css / js minify off – if it takes longer to fix i will do a rollback to version

    i still have saved settings for the older version and the deinstallation i read is plainless & clean.

    +1 for me, too. WP3.1.2, W3TC 0.9.2

    Love the plugin, but just this morning awoke to hear from my client that their website is showing unstyled content. Sure enough, I check the site, and it seems that all content is being shown as raw, unstyled HTML.

    On a hunch, I deactivated W3TC, and the site comes back looking fine. I’ve tried flushing the cache, but the plugin just goes to a blank screen. Also, when I try de/reactivating it, I just get the following error message:

    Warning: Cannot modify header information – headers already sent by (output started at [THEME FILE PATH]/functions.php:259) in /home/mahercom/public_html/wp-includes/pluggable.php on line 897

    Not sure what other info you need, but hopefully this is helpful!

    From @w3edge on twitter “users need to switch minify to manual minify mode”.
    The fix seemed to work for me.

    Just upgraded to 0.9.2 and got NO THEME CSS on both sites. Under General Settings – Minify – Minify Mode, I switched to manual and it fixed it for me. Will be watching for a permanent fix.

    Thanks obrun

    That worked for me after I cleared all the caches out.

    I am not exactly sure what the minify does but hopefully it will be fixed soon

    “users need to switch minify to manual minify mode” That worked for me on two sites.

    did this to everybody… minify to manual mode then flush and it worked on some sites but still had issues on other sites. After a bunch of flushes it seems to shake loose. I don’t think the flush always works.

    If you turn it on MANUAL and don’t ADD any of your themes files that you want minified, then it’s like turning it off! So of course it fixed, but it’s really not fixed. You have just turned off the Minify option.

    @realtyrealized – confirmed!

    Switching to manual does not work if you also add urls of the files that should be minified.

    Sad day for plugin author… 🙁 Guess we all know what he’s working on today!!!! minify Dead on Rackspace CloudSites Hosting.

    Guess this problem still isn’t fixed. Only solution was to turn off Minify. Just updated to the latest version of the plugin and it still has this problem.

    Noticed the minified css files used to be in separate folders for each site in the multi-site, now files are being generated in the main w3tc folder, but the stylesheet link is incorrect.

    Tried auto and manually adding the CSS files, got a different stylesheet link structure, but was still incorrect.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] [W3 Total Cache] Have the same problems with broken CSS & more’ is closed to new replies.