WordPress.org

Forums

Helping a friend w/ WP - How to restart/discover new files? (10 posts)

  1. free-awt
    Member
    Posted 1 year ago #

    I'm a complete newcomer to WP, but a friend of mine who isn't particularly web-literate asked me if I could help her with uploading issues, and I figured I would try. To try to be as clear as possible...

    Initial problem:
    * File uploads are limited to 7MB, but she wants to upload media files that are greater than 7MB.

    What I've done:
    * Created info.php in /wp-admin for her site, checked it out, found that the loaded config file is at /etc/php54/php.ini. I went and created that path and file and put the following in the file verbatim, so perhaps there's something wrong here:

    post_max_size = 64M
    upload_max_filesize = 64M
    max_execution_time = 500
    max_input_time = 500

    * Waited for a while to see if the change would take effect.

    Remaining problems:
    * It seems like the WP framework isn't picking up the changes that I've made to the loaded configuration file. I did notice that the permissions on the file *do not* include +x.
    * I only have FTP access, and neither I nor my friend are clear at all on how I can get CLI/SSH access to her WP instance.

    Does anyone know what I could do to close this issue? Thanks in advance!

  2. Chris Hardie
    Member
    Posted 1 year ago #

    You can see a couple of different techniques mentioned here for how to increase the file upload size limit in effect on your site:

    http://www.wpbeginner.com/wp-tutorials/how-to-increase-the-maximum-file-upload-size-in-wordpress/

    I would suggest contacting your web host / server administrator to see if they can help you determine where the upload limit is being set, and how to change it.

  3. Pioneer Web Design
    Member
    Posted 1 year ago #

    Created info.php in /wp-admin for her site, checked it out, found that the loaded config file is at /etc/php54/php.ini. I went and created that path

    Why are you creating a path that exists? The path is at server level. Please consult host.

    Also a phpinfo file should be at host account root (not in wp-admin of a folder).

    The file at root anyname.php (not a default WP file) will contain just this:

    <?php phpinfo(); ?>

    And as noted, discuss this with your host.

    and when browsed to will reveal some server information.

  4. free-awt
    Member
    Posted 1 year ago #

    None of those methods appear to have worked.

    Unfortunately this was a student organization that really has no proper administrator; some alumni of the group threw this together over the years and no one there now seems to know how it works. I really think I just need to figure out how to 'restart' the application. But maybe giving some more information might help.

    You can see the information from php.info() here: php.info()

    So I created /etc/php54/php.ini as it would suggest. However, that didn't work (=> why I'm still looking for help...). It might be, though, that the organization of this seems to be VERY non-standard. A lot of guides suggest that I should be seeing a basic Linux-like standard tree when I get in here with things like /user and /home and /etc, but none of those existed when I started. You can see some of the root here (cut for privacy): Root folder (I created the "home" folder.)

    Inside the folder of the site which they want, this is what I'm seeing: Site folder.

    Does this provide any more helpful information to you? Is there perhaps just another place in the configuration that I need this other than (verbatim) /etc/php54/php.ini? If I do need it right there, how can I restart the application? Thanks again.

  5. Pioneer Web Design
    Member
    Posted 1 year ago #

    Your link is not to a phpinfo file for your site but an obscure IM link (jpg).

    Please follow forum rules and not post links as such.

    (Same for the other links)

    The purpose of the phpinfo file is to review server info...a jpg can be from anywhere.

  6. free-awt
    Member
    Posted 1 year ago #

    What's wrong with screenshots? It's a screen grab of the result of accessing mysite.com/wp-admin/info.php. I didn't see anything in the rules about not posting images.

    If you want the output here:

    System: Linux yildun 2.6.32.45-grsec-2.2.2-r3 #8 SMP Mon Oct 10 13:33:17 PDT 2011 x86_64
    Build Date: Oct 30 2013 23:28:50
    Configure Command: [snipped for length]
    Server API: CGI/FastCGI
    Virtual Directory Support: disabled
    Configuration File (php.ini) Path: /etc/php54
    Loaded Configuration File: /etc/php54/php.ini

    I created /etc/php54/ as a path because, if you check out the image of my / directory when I logged in to FTP, there was no such path. It seemed to me that the app was looking for an ini file in a location that didn't exist, so I tried making it.

  7. Pioneer Web Design
    Member
    Posted 1 year ago #

    The path /etc/php54/ is at the server level - please consult webhost about use of a php.ini file. If allowed, it would go in the root of your host files. You may need to restart server processes for it to be loaded. You will know if it is by reviewing the phpinfo file.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    Does your friend have FTP access?

  9. free-awt
    Member
    Posted 1 year ago #

    Yes, and she's given me access to her account temporarily, so I also have FTP access for the time being.

  10. esmi
    Forum Moderator
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Topic