Support » Fixing WordPress » Help WP_Error when saving pages

  • Has anyone seen this problem. I get a

    “Fatal error: Cannot use object of type WP_Error as array in /home/public_html/wp/wp-includes/taxonomy.php on line 1010”

    whenever I save or edit a Page in WordPress 2.3. I can edit posts without a problem but the error occurs whenever I save/edit a Page.

    I have uninstalled all my plugins, re-installed wordpress and deleted all my blogroll but the problem persists!

    Thanks to whoever can help.

Viewing 14 replies - 46 through 59 (of 59 total)
  • Reinstalled the 2.3.2 update of wordpress. same problem still exists in the taxonomy.php file.

    I am thinking more that this error is related to the wp-ecommerce plugin, which I used for only a few hours before this showed up. the plugin has been deactivated since that first day, but the problem still exists.

    now the patch from “therealwb” at line 1008 does not seem to work for 2.3.2 update.

    any ideas out there?

    If someone is experiencing this problem, and is willing to give me access to debug the problem on their site, please contact me lloyd @ wordpress.com .

    Hi sheatsb and others I too have wp e-commerce and have the same problem with the taxonomy issues. If it is related to wp e-commerce then this is a further problem as this plugin is not very well supported by the developers. Do you think its worth posting this post to them ?

    Also how many people have this commerce plugin and are having the same problem?

    I put a post on the e-commerce site months ago, but no result. Looks like this one’s in the too-hard basket.

    Ok I dont know how permanent this fix is but I went back to php 4 and I all of the sudden was able to post images again. If anybody else has access to this option please try it and post here to let everyone know it is a php 4 vs. php 5 issue

    Hi Guys, Dan here from the WP e-Commerce team.

    We’ve had a look into this and it appears to be a bug in WordPress. It has been identified by WordPress and it is going to be fixed in WP 2.5

    This is unfortunate for us (and our reputation) because it appears that one of the WP e-Commerce functions that utilizes taxonomy (tagging) hooks triggers this evil WordPress bug.

    What we’re trying to do is modify our code so that it doesn’t trigger this bug. We’re aware of this now and we’ll try to work it out…

    Hi, Guys

    Allen here from WP e-commerce team.

    Here is a fix to that “WP-Error” error go to wordpress admin page, go to options->writing select a Default post category and save the change.

    We are still trying to find that anything in our code triggers the bug, but for the two site i have fixed, both of them have like more than 20 plugins,it is really hard to tell which plugin causes the error.

    The two sites we looked at both also had the Admin Drop Down menu plugin installed… but there was nothing we could find to suggest it was that either.

    So in that sense we’re stumped… the good news is though that Allen found an easy fix and the WordPress bug itself should be fixed in 2.5

    d

    Nice one Allen, that seems to have done the trick. I had the problem, but didn’t have the Admin Drop Down menu plugin installed.

    Don’t know if this helps anyone, I had this issue when upgrading versions of WordPress on Dreamhost, the upgrader seems to have forgotten to add the tables for wp_terms, wp_term_taxonomy and wp_term_relationships.

    I had the exact same error when creating a post, and after adding the tables, the error went away…

    Thank you Allen, I know which two sites you where looking at … mine and you have done good my friend !!! . I do have 20+ plugins in the folder but only about 7 activated …anyway the fix works great
    all the best
    G

    Many thanks hanzhimeng (Allen!) _ I was getting so depressed reading this thread and I’m so glad things came good when I got to your posts. All working for me now. Thanks.

    I got the same problem yesterday because of a reinstallation.
    I exported data with built-in wp feature.
    Backed up mysql tables.
    Wiped out the server folder.
    Reinstalled another clean wordpress (the version was the same).
    Imported back my data with wp feature.
    And I lost all my categories and tags (that was not a problem).

    After this I got that error when saving pages/articles and trying to upload data.

    It simply solved itself by publishing a post with a temp category and a temp tag.

    I hope this helps.

    HI. This has something to do with wp-ecommerce. The problem for me was that i had a product category with no name. I deleted that one and everything works just fine.

Viewing 14 replies - 46 through 59 (of 59 total)
  • The topic ‘Help WP_Error when saving pages’ is closed to new replies.