Support » Fixing WordPress » Help WP_Error when saving pages

  • Has anyone seen this problem. I get a

    “Fatal error: Cannot use object of type WP_Error as array in /home/public_html/wp/wp-includes/taxonomy.php on line 1010”

    whenever I save or edit a Page in WordPress 2.3. I can edit posts without a problem but the error occurs whenever I save/edit a Page.

    I have uninstalled all my plugins, re-installed wordpress and deleted all my blogroll but the problem persists!

    Thanks to whoever can help.

Viewing 15 replies - 1 through 15 (of 59 total)
  • I too am getting this error – oddly only on a live version of the site. The dev site served on a local machine is not exhibiting this behavior.

    For the record I get it when editing/creating Pages or when adding images to posts (uploading media).

    Any help is appreciated.

    A little more info – this happened under WP 2.2.1 on both live server & dev server, but after upgrading to WP 2.3 it only affects the live server.

    And some more info – I am beginning to believe this is database related…or at least related to WP reading/accessing the database. I created a new database for the site and everything worked *except* for adding media to pages/posts. That is still the only place I am getting a WP_Error as array…

    Very troubling – I may have to move from WordPress and find an alternative.

    same error – :

    Anyone recommend anything?

    Fatal error: Cannot use object of type WP_Error as array in /home/stadiumb/public_html/wp-includes/taxonomy.php on line 1010

    I have deactivated all pluggins and tried again and still no luck.

    I’m going to delete my entire site and database and start from scratch. I wish I new enough about this to know if I could restore the database or if the corruption is there or not. I will update to this topic for you guys.

    Not sure if this is the same as the problem i had, seems to be different error messages but the same behaviour.. have a look, see if this helps

    I was excited to try something – anything – but it was not the fix i needed.

    Thanks for suggesting!


    deleted my wordpress folders, deleted my database. re installed. Everything is just about back as I had it – I did not trust restoring database, re-entered everything. so far it is working. Don’t know where the problem was or what happened.

    same thing here.. still cann’t post.. so did andybody have any solution rather then reinstall wordpress

    no – and a reinstall helped me with about 90% of my issues but was not a total fix (I can post & edit but cannot upload/ad images to pages or posts). Seems like a serious issue with WordPress. I’m currently investigating other options and keeping my fingers crossed that a solution is posted soon and I don’t have to move to another platform.

    its not a general issue, or loads more people would be reporting it, i’ve done both an install of 2.3 and an u/g both fine too.

    Can I suggest you all start comparing notes on your server platform/set up etc to try n find some common cause perhaps?

    is it possible that problem is caused by PHP version 5.2.4???
    because our servers was updated to this version of php and somewere in the same time started all proplems with wordpress…

    I get this problem when I try to save/publish pages and/or upload images.

    I am running 3 WP installs on the same server, 2 work fine and 1 craps out with the referenced error. So, it’s not PHP, it’s not MySQL. For the record the 2 that work are *not* 2.3. One is 2.12 and the other 2.23 (I believe, maybe it was 2.22 – whatver the last 2.2x version was).

    Oddly the same v2.3 site works fine on my dev server.

    I’m going to give it one last try and delete the entire site (it’s still in the staging phase) to see if that solves my issues.

    I recently blew away the DB and that solved everything except the upload of images. So…I don’t know what the deal is.

    …keeping fingers crossed…

    yepp.. situation here is the same.. i run few WP 2.3. intalation on server and only with one I have problem, it problems with upload pictures.. I’m hoping that wp. 2.3.1 update will fix that

Viewing 15 replies - 1 through 15 (of 59 total)
  • The topic ‘Help WP_Error when saving pages’ is closed to new replies.