WordPress.org

Support

Support » How-To and Troubleshooting » Help! WordPress Killing the CPU

Help! WordPress Killing the CPU

  • Help! I’m desperate.

    Last week my WordPress site was shut down by my hosting provider for overwhelming the CPU. They’ve reactivated the site, but given me only a few days to find and resolve the problem. They keep pointing to WordPress, and my own troubleshooting reveals that it can only be WordPress.

    The site is http://quarkvsindesign.com. As of the 17th, it has been hitting 99% CPU usage on all four processor chips on the server. I don’t have the history prior to that, but I’m told it was hitting high points below 10%. The host’s server logs say the CPU usage is due to /usr/bin/php, but they can’t be any more specific than that.

    In troubleshooting, I’ve disabled everything PHP except WordPress Strayhorn 1.5.2.

    It’s not a hacked install, and I took the templates down to absolutely barebones in the course of troubleshooting–a solitary index.php and a single.php, no header.php or footer.php even. Traffic didn’t spike on the 17th, and the site’s overall traffic is only about 13% more than the previous month–it’s not enough to cause the CPU time to increase tenfold.

    I’m a level-headed and experienced technical troubleshooter (not a programming or network pro, however), but I’m completely lost here. I’ve tried disabling plugins (nothing atypical there anyway), with abosolutely no change. I even rolled the posts published since then back to draft status with no change in CPU usage. Everything but WordPress has been disabled, and the CPU usage is still astronomical.

    I would appreciate ANY help on this. Thank you.

Viewing 15 replies - 1 through 15 (of 24 total)
  • So…what plugins do you have loaded anyway?

    Moderator James Huff

    @macmanx

    Support Team Rep.

    Yes, try disabling all of your active plugins.

    How did you track it down to WordPress?
    I noticed that my browser (FireFox) never says “Done” but only “Transferring data from …” – although the page seems to be OK and nothing is downloaded according to my bandwith-monitor.

    Some thinkings:
    o) look for open Tags
    o) look for “maximum execution time” in php.ini
    o) double-check that rewrite-stuff in .htaccess – once had the same problem with mod_rewrite on one of my projects (not wordpress-specific!)

    Hmm. Thanks FHT. I’ll have to check into the efficiency of my .htaccess files.

    I’ve handled the problem by installing WP-Cache (plugin).

    I don’t believe I resolved the issue, just fixed the symptoms. That will keep my site from being shut off by the host, but I’d still like to track down the real cause.

    How did I track it down to WordPress? Well, the server CPU stats reported that the high usage was caused by PHP scripts. After I disabled everything else PHP on the site, WordPress was the only thing left and the CPU usage was the same.

    I don’t necessarily believe WordPress has a fault in it, just that WordPress (or some module of it) is the reason the CPU is maxing. It could be anything from increased traffic to the site (already ruled out) to poorly coded templates from the user (already ruled that out too).

    The real kicker is, the CPU shot up on a specific day and remained high since. I changed nothing in the site on that day or immediately before it. Normally my first troubleshooting step is to look for user (my) error. In this case, that wasn’t a factor–although I troubleshot for it anyway by using 3 month old backups, just in case I changed the templates or hacked the WP code without telling myself.

    Search engine traffic increased, but not a great deal. I did throttle the search engines back by telling bots through robot.text to wait 20 seconds between each page request. Still, 99% CPU after that.

    It’s perplexing. With WP-Cache I’ve been given breathing room to work on the problem without worrying that my business is going to go down. But, I still want to find the actual ailment instead of treating the symptoms.

    I’ll look into the .htaccess and mod_rewrite rules. Maybe I goofed it months ago, but it was only on 17 Oct (and later) that some other factor caused that mistake to become an issue.

    Mark (podz)

    @podz

    Support Maven

    I read somewhere in the last week that mod_rewrite can do this – but as usual in such cases I can’t recall where.
    I’ll search and if I find, I’ll post back.

    podz, I think that was the thread linked above….

    Mark (podz)

    @podz

    Support Maven

    vkaryl – I’ll be the one with the faulty memory then 🙂

    I have the same problme, my host called me 2 weeks ago about the CPU overload on the server. So we set all the plugin off, the load dropped till normal procedure.

    I just installe the sats script Bbclone, and there is see my weblog is very often visited my viagra site:
    http://www.buxx.nl/blogg/bbclone/show_detailed.php?lng=nl

    What can it be, as far as i know, there is no known leak in WP.

    Wow, you’ve got tons of crap hits there…. not just the viagra sites, but all the Russian and 3rd world “pharmacy” sites, etc. Are you using anything to combat referrer spam or anything like that?

    Not right now, but i do not have problems with spammers om comments.
    Only a whole lot of visitor. What sort of plugin can i use for preventing this?

    Mark (podz)

    @podz

    Support Maven

    Bad-Behaviour will stop some:
    http://www.ioerror.us/software/bad-behavior/

    Referer Karma will catch others:
    http://unknowngenius.com/blog/wordpress/ref-karma/

    I use both.

    Okay, i’ll give it a try.
    But, i have no problem with te comment spam, pnly visits from spammers, they do nothing woth my site further as i see.

    Iampariah: I’m getting the same CPU Quota Exceeded error from my server over the past wk or so.

    As with the user who created the post linked above I have mutilple .htaccess files in folders. SO that may be causing the problem. However, I’ve had such multiple files for months & the CPU error has never happened before.

    I installed Cache too & it really speeds up performance. Though I’ll have to wait to see if it stops the CPU errors.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Help! WordPress Killing the CPU’ is closed to new replies.