Support » Installing WordPress » Help with upgrade error message

  • I upgraded to 3.0.4 and at first it worked and now I cannot access the admin page. I get the following error message: Warning: Cannot modify header information – headers already sent by (output started at /home/agapelov/public_html/jesuisneefemme/wp-config.php:1) in /home/agapelov/public_html/jesuisneefemme/wp-includes/pluggable.php on line 890.

    I did some troubleshooting using this link:

    No success.


Viewing 15 replies - 1 through 15 (of 15 total)
  • If you have checked the php code for whire spaces, try checking your plugins, if you can access your site rename the wp-content/plugins directory to wp-content/plugins.hold

    This should start you with no plugins and you cans see if the same issue occurs.

    As stated above, it may be a plugin issue. Rename the Wp-content > plugins file, then once you get it working properly rename it back to the original file name and activate your plugins in the WP-admin/plugins area.

    Thanks @zybrite, forgot to mention putting it all back if it works!

    Since you can not access your admin panel to deactivate your plugins you will need use ftp or server to log in on your host account and rename plugin folder like @datasoftict suggested.

    Thanks everyone for such a quick response…I did what you suggested but no change when I type in, I still get the same message I mentionned above. It’s very strange because it worked initially and then I got an error message about memory size. I did what my hosting provider said (ACE.NET) to increase the PHP memory size and then that’s when I got this error message about pluggins. Do I have to do a new installation on a new ftp account and start my site all over?

    What exactly did your host tell you to do in order to increase the memory?

    I would reverse that first to see if the site works again and if so then go ahead and check in the codec on how to increase memory the right way.

    I see some  characters above the error message – could be the result of what was added to increase the memory.

    check your wp-config.php if there is a blank line before <?php as there should be no blank line or space and last line is ?>

    check your wp-config.php if there is a blank line before <?php as there should be no blank line or space and last line is ?>

    thank you,

    I see you are still having problems with this. If you can upload ftp files try uploading a file with the following code

    ‘<?php phpinfo(); ?>’

    into your directory.
    If you give it a name like siteinfo.php and add the code above, the go to and see what information comes up, check the memory figures. I understand that there *could* be a problem on windows servers so are you on windows server running php and mysql?

    For my own interest I have just uploaded several copies of my wp-config file to one of my test sites with white spaces, then newlines and then returns at the top before the <?php and then again at the foot and nothing stopped the loading of the admin page.

    I think you need to look at your wp-includes directory and maybe ftp a new set to the site.

    Just to add to the above test, white spaces in wp-config *will* blow out the dashboard admin pages and they will not load – just show a white page. However the admin login will load and allow you to enter your account name and password.

    Hi everyone,

    Thank you for all of your advice. I tried all these things and still was getting no where so I deleted everything and uploaded everything back (from the back up I made) and now my site doesn’t even work anymore!!! HELP!!! I get this message: Fatal error: Call to undefined function wp() in /home/agapelov/public_html/jesuisneefemme/wp-blog-header.php on line 14.

    I’ve made a real mess out of this!!! I so need my site to work!!!! Please HELP!!



    Forum Moderator

    What version of WordPress were you previously using? And what version did you upload

    I was using 2.7.1 I believe…that’s the version my back up was with.

    Now I have my site back up again but I still can’t access the admin page. I’m not sure what the problem is anymore. I still get the same message on my admin page: Warning: Cannot modify header information – headers already sent by (output started at /home/agapelov/public_html/jesuisneefemme/wp-config.php:1) in /home/agapelov/public_html/jesuisneefemme/wp-includes/pluggable.php on line 868.

    Is there anyone at WordPress I can contact to fix this issue? I want to be able to work my site! Thanks!

    Ok! I finally did it! I just uploaded a new wp-config.php file and now I’m good! Thanks everyone! 🙂

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Help with upgrade error message’ is closed to new replies.