Support » Plugin: Wordfence Security - Firewall & Malware Scan » Help with SiteGround and optimizing the Wordfence Web Application Firewall

  • Hi,

    I have several websites in my account on SiteGround. I have tried to follow instructions to optimize the Wordfence Web Application Firewall, but it still says it needs to be optimized.

    I followed these instructions on two of the sites (main and one of the add-on domains):

    Go to your site’s cPanel, and click the PHP Variables Manager icon.
    3) Click the link that says “public_html“.
    4) Enter auto_prepend_file as the variable name, click the “Add” button, and then enter the path to your “wordfence-waf.php” file.
    5) Turn on the checkbox “Apply changes to all sub-directories” and click Save.

    The sites both load fine, but still say they need to be optimized…

    Can you help?

    Thanks,
    Tammy

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @tcaywilson,

    Please make sure the value you entered for “auto_prepend_file” is taken into account; this article explains how to check.

    I also recommend this post which discusses a similar issue.

    Let me know if that helps.

    Thanks for the help. I followed the instructions in the Flying V Group video and the first site I did it on worked. But the other sites said “Installation Successful” and “The changes have not yet taken effect…”. I’ve wait and refreshed, but still showing the message that the firewall needs to be configured.

    I’ve checked the Diagnostic’s–System Config and auto_prepend_file has the correct value in both local and master columns.

    While doing this, I now have a weird error on one site “Warning: count(): Parameter must be an array or an object that implements Countable in /home/…/wp-includes/post-template.php on line 284” I’m wondering if I messed something up when changing the PHP variable…

    Contacted SiteGround and they say WordFence is not 100% compatible with PHP version 7.2. They changed my PHP version to 7.0.29 and now it’s working.

    Changed the PHP version on my other sites and I’m still getting the optimize message. I contacted SiteGround support again and they said “You just need to make sure that it is not in learning mode and set it to Enabled and protected.

    You should then dismiss the notice:

    But as far as I can see it is already enabled for these sites. Are you getting an error?”

    I’m assuming dismissing the notice is not the proper way to handle this and I still have problems?

    Any other suggestions, comments?

    Thanks, Tammy

    Hi @tcaywilson,

    Indeed, “dismissing the notice is not the proper way to handle this“.

    Can you confirm that on the other sites you mentioned in your latest post the value you entered for “auto_prepend_file” is taken into account?

    Also could you please check with your hosting provider if somehow they’ve disabled the use of “auto_prepend_file” for those environments?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Help with SiteGround and optimizing the Wordfence Web Application Firewall’ is closed to new replies.