Support » Plugin: Yoast SEO » Help with no indexing a dynamic URL

  • Resolved pleazo



    I am using the Dokan plugin for my online marketplace. When a new vendor signs up, they get the following pages created:

    I want to set urls which have “/toc/” & /reviews/ in them to noindex. These are dynamic URLS which I cannot seem to do in the Yoast plugin.

    I already spoke with my hosting provider which gave me the following info:
    “Enter this in my robots.txt instead:
    Disallow: /toc”

    But it is not working since is still showing as index.

    What is the easiest way to set these URLs to noindex?

    I am not familiar with Apache servers (neither was my hosting provider) nor wpseo_robots. Is there an easier way to do this?


Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Maybellyne


    Hello Chris,

    Thanks for reaching out again regarding this.

    Unfortunately, there is no setting in the Yoast SEO plugin to noindex dynamic URLs. The only option is to do it programmatically. This is done by using the wpseo_robots filter.


    Thread Starter pleazo


    Hi @maybellyne thanks!

    How about setting canonical URLS for the ones below to /vendorname/ ?

    Would I still need to do this by using the wpseo_robots filter? Or is there another way?


    Plugin Support Michael Tina


    Hi @pleazo

    To change the canonical URL that Yoast SEO generated for a URL programmatically, you can use the wpseo_canonical filter.

    You can learn more about it here –

    Plugin Support devnihil


    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.