Support » How-To and Troubleshooting » [Resolved] Help with .htaccess permissions

[Resolved] Help with .htaccess permissions

  • Ok. So I’m going to break it down for everybody and let you know exactly what happen leading up my question… First off yesterday around noon, my site was loading super slow so I called my hosting provider and informed them of the problem. They told me the reason was that I probably needed to upgrade my wordpress to 2.6. I was currently at version 2.51. Anywho, I asked the rep if my blog was going to be ok and everything would remain the same… he said yes. I hit the automatic upgrade button via my hosting account with my hosting a company and just waited. About an hour later I get an email saying I have finished installing version 2.6, I immediately go to my blog and it is showing up plain text (this shouldn’t happen my current theme is http://themebot.com/website-templates/wordpress-themes/659-sphinx), white background, none of the pictures are showing up or anything. So I click on where a picture is suppose be and locate the file location. I then go to my ftp and locate the exact image location…. and its exactly where its suppose to be. So why isn’t my blog pulling up the image? And why isn’t any of my theme pulling up… I am fairly new to wordpress but pick things up really quickly, I’m also can’t write code or anything like that… I can read some of it and do easy tasks such as replacing pieces of code with no code and what not… Anyways somebody at my hosting company told me it was probably something do with the permissions with .htaaccess in my… well I think the /wp-content folder… I dont know though, I dont know too much about .htaaccess except for what does and what not. But if somebody could please take help me out a little bit if you think you might know what the problem is it would be appreciated as my site is currently down and temporarily being forwarded to another site with a “temporarily unavailable page”

    Also I did downgrade back to 2.51, deactivated all my plug-ins… tried all that…

Viewing 15 replies - 1 through 15 (of 22 total)
  • Jeremy Clark



    You need to give a link to the blog that’s having the problem. It’s much easier to diganose when we can see what’s happening.

    the blog is notsomotivational.com, but it is being forwarded to one of my other sites right now because the site is all text and doesn’t show any images. Rather than showing people that I am showing them a temporarily unavailable page. (I get about 2000 people a day to my site and have over 15,000 rss readers… I dont want to show a site that is all messed up if you know what I mean. Basically nothing is showing up like it should but everything is suppose to where its at as far as all my images are concerned.

    1. Don’t use automatic upgrades.
    2. It probaly messsed up your site_url and home values – the two URL values in admin > Settings > General.
    3. On a side note: a correctly coded WP theme should be OK even without the stylesheet… at least it should display the content in a nice semantic markup.

    ok, but I already did use the auto upgrade… so you think that it is not the .htaccess? I agree with you on #3… it should at least be showing images and my links should be working if it just were the stylesheet… but I and that guy at my hosting company thinks its the htaaccess permissions because all of the files are exactly where they are suppose to be…. their just not being read.

    Now you and that guy can argue with me all day long… it’s not my blog, so I really don’t care how long it will be down. But what you described:

    my blog and it is showing up plain text

    is a typical phenomenon when the installations doesn’t see the style.css or is looking for it in the wrong place.

    Now, if both of you are so convinced that the .htaccess file is causing it – what is stopping you from removing it?

    And as long as you keep that splash page there – nobody will be able to give you any useful advice.

    I’m not trying to argue man…. I’m just going to to undo the redirect. I’ll post again once its back.

    ok… I changed the a record back to my blog. It should be back up soon. Again, the site is notsomotivational.com

    What records? I thought you had a temporary file there, which should be changed immediately as ssoon as you removed it.


    temporarily being forwarded to another site with a “temporarily unavailable page

    The site should be back soon though so you can see it as the text version with all the errors.

    alright you can go to my site now and view it…


    What I said: the stylesheet is not there.

    And don’t double post because I am very fast with the Delete button 🙂

    so reinstalling the theme or “a theme” should work? Sorry, like i said, Im not a coder or anything im not too familiar… I dont want to go change stuff around, is it easier to just reinstall?

    No, reinstalling is a mad obsession of newbies… It never solves anything.

    Did you check whether your theme(s) are there or not? Use your FTP client to see the files/folders on your server.
    You don’t need to be a coder for that.

    The style sheet is at http://notsomotivational.com/wp-content/themes/sphinx/style.css – its just not showing up… same thing with my images and other links. Is it cool to post a screenshot of my ftp client as long as there is none of my personal info and what not?

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Help with .htaccess permissions’ is closed to new replies.
Skip to toolbar