WordPress.org

Forums

Need help removing gray border (9 posts)

  1. lizvoss
    Member
    Posted 5 years ago #

    I am trying to get rid of the gray border on my blog located @ http://lizvossrealestate.com/blog/. It's the one located around my content page and is probably 2-3 pixels wide. I have tried everything to no avail, and it's driving me crazy. Can someone help, pleeeeeease.
    Thanks, Joel

  2. cnc137
    Member
    Posted 5 years ago #

    The border you are talking about is actually images that are located here:

    - http://lizvossrealestate.com/blog/wp-content/themes/default/images/header-img.php?upper=8e7353&lower=bfa378
    - http://lizvossrealestate.com/blog/wp-content/themes/default/images/kubrickheader.jpg
    - http://lizvossrealestate.com/blog/wp-content/themes/default/images/kubrickbg-ltr.jpg

    These files are defined in your "header.php" file of your theme in the section that looks like this:

    <?php
    // Checks to see whether it needs a sidebar or not
    if ( empty($withcomments) && !is_single() ) {
    ?>
    	#page { background: url("<?php bloginfo('stylesheet_directory'); ?>/images/kubrickbg-<?php bloginfo('text_direction'); ?>.jpg") repeat-y top; border: none; }
    <?php } else { // No sidebar ?>
    	#page { background: url("<?php bloginfo('stylesheet_directory'); ?>/images/kubrickbgwide.jpg") repeat-y top; border: none; }
    <?php } ?>

    I hope this helps.

  3. lizvoss
    Member
    Posted 5 years ago #

    Thank you, Thank you. That did the trick for the side borders, but how can I get ride of the header bar. It's still there even after I removed your above code which took care of another problem I didn't like, the plain white background.

    - http://lizvossrealestate.com/blog/wp-content/themes/default/images/header-img.php?upper=8e7353&lower=bfa378
    - http://lizvossrealestate.com/blog/wp-content/themes/default/images/kubrickheader.jpg
    Thanks for the help.

  4. cnc137
    Member
    Posted 5 years ago #

    You will need to edit a two more files to remove the header image.

    Edit the "Stylesheet (style.css)" file and find the following lines:

    #header {
    	background: #73a0c5 url('images/kubrickheader.jpg') no-repeat bottom center;
    	}

    You need to comment out the "background" image by changing the above code to look like this:

    #header {
    /*	background: #73a0c5 url('images/kubrickheader.jpg') no-repeat bottom center;  */
    	}

    Next, you need to edit the "Theme Functions (functions.php)" file and find the following line:

    add_action('wp_head', 'kubrick_head');

    Add two slashes in front of that line to comment it out so that WordPress doesn't call the function to make the custom colored header image. It should look like this after you are done:

    // add_action('wp_head', 'kubrick_head');

    That should remove the background image at the top of your theme.

    You may also want to read this article about the WordPress Default Theme header image and how you can change it:

    http://www.aetas.dk/archives/8

  5. lizvoss
    Member
    Posted 5 years ago #

    Wow great article and you guys are good. I also appreciate you taking the time to answer my questions. I can use FrontPage and DreamWeaver, but PHP is new to me. My whole objective is to try and get my blog page to mirror our web site http://www.lizvossrealestate.com/ as close a possible. You know, the rounded corner thing along with the look and feel. I've expanded the page and with your help was able to remove the gray. Can you tell me how I can align left my links while leaving the names such as "Archives", "Recent Post" ect. centered? And can I do the rounded corners, or will you hire out?
    Thanks so much for the help, Joel

  6. cnc137
    Member
    Posted 5 years ago #

    It is possible to align the <h2> tags (i.e. Archives, Recent Post, etc.) centered while aligning everything else to the left. You would need to set the text-align property to "center" or "left" depending on which item you are styling.

    I think if you change the following in your "style.css" file it should make the <h2> tags centered:

    Change this:

    #sidebar h2 {
    	margin: 5px 0 0;
    	padding: 0;
    	}

    to this:

    #sidebar h2 {
    	margin: 5px 0 0;
    	padding: 0;
            text-align: center;
    	}

    Then I believe you would need to change the following:

    #sidebar ul, #sidebar ul ol {
    	margin: 0;
    	padding: 0;
    	}

    to this to align the rest of the content to the left:

    #sidebar ul, #sidebar ul ol {
    	margin: 0;
    	padding: 0;
            text-align: left;
    	}

    I think that will work, but I was trying to look at your HTML and CSS code to find where you are setting everything to be centered and couldn't find it in my brief scanning of the code.

    The rounded corners are also possible, but a little more complicated than what can probably be covered here in a quick post. There are tutorials online about rounded corners if you search for them on Google.

    Also, I am available for freelance work if you would like me to help you make your blog match your website. You can visit my website http://cnc137.com to find out more about me and to view my portfolio. If you would like to get in touch with me, then you can find that information there also if you would like me to help.

  7. lizvoss
    Member
    Posted 5 years ago #

    That did the trick and I sent you a meeting invite for tomorrow as well. I have one last recommendation for now that's driving me bonkers. On the page http://www.lizvossrealestate.com/blog/ I have the title to the latest blog set up like the blog page title, but it doesn't work. I can hover over San Antonio Real Estate and it underlines, turns maroon after visiting, and is blue prior to the visit. Setting the list price on real estate is supposed to be doing the same thing, but is only turning maroon after the visit. Can you once again help????? Thank you for everything you've done so far it has all worked out like a champ and has gotten things looking really much better than what I had.
    Thanks again, Joel.

  8. cnc137
    Member
    Posted 5 years ago #

    I got your invite and accepted and plan on talking to you tomorrow.

    Now onto your question/problem...

    I looked at your CSS file and you have multiple definitions of how links should be styled for <h2>, <h3> and "a" tags.

    The last definition is as follows:

    a, h2 a:hover, h3 a:hover {
    	color: #06c;
    	text-decoration: none;
    	}
    
    a:hover {
    	color: #147;
    	text-decoration: underline;
    	}

    The above is way down in the "style.css" file and is overriding the CSS defintions above it.

    I would delete the CSS code above from your CSS file, since I don't know why it is there further down in the file and it is overriding the definitions above.

    It is called a cascading style sheet (CSS), since the above definitions cascade down and also can be overridden by definitions further down in the CSS file for the same thing. So, you are overriding the definitions for "a, h2 a:hover, h3 a:hover" and "a:hover" that is specified earlier in the CSS file.

    I just noticed that you keep defining "a" at the beginning of every style and you don't want to do that either in the upper CSS definitions. This is redefining the CSS for an "a" HTML tag over and over. You may want to revert back to the default CSS, as seen below, and go from there.

    h1, h1 a, h1 a:hover, h1 a:visited, #headerimg .description {
    	text-decoration: none;
    	color: white;
    	}
    
    h2, h2 a, h2 a:visited, h3, h3 a, h3 a:visited {
    	color: #333;
    	}
    
    h2, h2 a, h2 a:hover, h2 a:visited, h3, h3 a, h3 a:hover, h3 a:visited, #sidebar h2, #wp-calendar caption, cite {
    	text-decoration: none;
    	}

    Change the default to something like this should do the trick:

    h1, h1 a, #headerimg .description {
    	text-decoration: none;
    	color: white;
    	}
    h1 a:visited {
    	color: maroon;
    }
    h1 a:hover {
    	color: #147;
    	text-decoration: underline;
    }
    
    h2, h3 {
    	color: #333;
    	}
    h2 a, h3 a {
    	color: #147;
    }
    h2, h2 a, h3, h3 a, #sidebar h2, #wp-calendar caption, cite {
    	text-decoration: none;
    	}
    
    h2 a:visited {
    	color: maroon;
    }
    h2 a:hover {
    	color: #147;
    	text-decoration: underline;
    }
    
    h3 a:visited {
    	color: maroon;
    }
    h3 a:hover {
    	color: #147;
    	text-decoration: underline;
    }

    This isn't the best CSS coding, but it should work. Also, it is important to define the "a" references always in this order in your CSS file for them to work properly:

    a
    a:link
    a:visited
    a:hover
    a:focus
    a:active

    I hope this helps and works.

    Talk to you tomorrow.

  9. lizvoss
    Member
    Posted 5 years ago #

    Chris,

    Can you help me out again and tell me where to insert the following script:

    a, h2 a:hover, h3 a:hover {
    color: #06c;
    text-decoration: none;
    }

    a:hover {
    color: #147;
    text-decoration: underline;
    }

    This was the piece we took out and then later spoke about. I'm trying to get the linked text to not underline unless hovered over. Have you given it anymore thought on what we talked about?
    Thanks, Joel.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags