The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

Help with Blogger Import (10 posts)

  1. patchmonkey
    Posted 11 years ago #

    Hey, I just imported 1000 blogger entries, but they don't come out right. None of them have the author's name attached, and they all give me this error:

    WordPress database error: [Unknown column 'dateYMDhour' in 'field list']
    INSERT INTO wp_users ( user_login, user_pass, user_nickname, user_email, user_url, user_ip, user_domain, user_browser, dateYMDhour, user_level, user_idmode ) VALUES ( 'Patch Monkey', 'password', 'Patch Monkey', 'user@wordpress.org', '', '', 'localhost', 'server', '1979-06-06 00:41:00', '1', 'nickname' )

    Any help?

  2. skeltoac
    Posted 11 years ago #

    Yeah, it's a bummer that it happens that way sometimes. But all that error means is that there was trouble creating the user record in your WP database. It's not critical, because as soon as you've finished categorizing those 1000 posts, they'll all show up with your WP Admin user as the author.

    I bet you miss your comments, huh? Go here to get a copy of the import-blogger.php file I just hacked out. It has the added benefit of importing your Blogger comments. If you follow all the directions, it should work fine.


  3. archshrk
    Posted 11 years ago #

    Can I import more than one blog to the same wordpress?

  4. sodafizz
    Posted 11 years ago #

    I’m having a problem with Blogger importing. I changed my Blogger date format to the correct option (the first choice in Blogger’s drop-down), and then changed the Blogger template to the required WP code. I ‘republished’ the entire Blogger blog (which I began in Jan 2005) so as to upload to my WP blog directory

    The “Archive� directory is now properly showing under my new WP blog directory as is a “2005� directory with subfolders for all months and all my old Blogger posts visible. I then went back to WP’s blogger-import instructions and clicked "Go". It then said “Done�. My WP directory now has the following subfolders:


    Everything appears where it ought to be, but when I sign in to WP and view my WP blog, none of these imported Blogger posts are showing…

  5. dgstinner
    Posted 11 years ago #

    Once your posts are imported, you can delete the old html files Blogger created. Everything from now on will be stored in the database.

  6. sodafizz
    Posted 11 years ago #


    I'm not sure you're understanding my problem: my imported Blogger posts are not showing up on my WP blog. (I am successfully making new posts to the blog however.)

  7. sodafizz
    Posted 11 years ago #

    The imported Blogger posts (which have .html extensions) are on my server, but are not showing up in MySQL database (while my “new� posts created in WP are showing up fine).

    When I had initially imported the posts from Blogger, and then went back to click "Go" at WP’s blogger-import instructions, it immediately went to "Done", which seemed odd and indicative that the posts did not even attempt to get uploaded to my db.

  8. sodafizz
    Posted 11 years ago #

    In the “import-blogger.php� file, in the code section that is activated when the importer is running (i.e, uploading to one’s MySQL db), I noticed one line of code that reads:

    $user_domain = 'localhost';

    I am among the 1% of wp-config setups that, in order to successfully setup WP, couldn’t use “localhost� but had to use:

    define('DB_HOST', 'mysql##.secureserver.net')

    Should I be changing the abovementioned line of code in the “import-blogger.php� file, replacing ‘localhost’ with ‘mysql##.secureserver.net’?

  9. injinuity
    Posted 11 years ago #

    well no, even I am on godaddy and I imported without changing any db info

  10. sodafizz
    Posted 11 years ago #

    I fixed it! I figured out what I was doing wrong. It is imperative to have your Blogger’s “Archive Path� setting in the root directory that your WP files are in. See http://catsutorials.catsudon.org/?p=15. I had mine in a sub-directory folder called “/archive� which was the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.