Support » Installing WordPress » help – upgraded – now cannot Edit Posts or Add New Posts

  • i was using wordpress 2.7.1 and it was working fine (although highly outdated and lacking any new robust features).

    i upgraded today to the latest and greatest 2.9.2
    install went fine
    i can log into wp-admin just fine
    when i click on Posts and then Add New Posts or Edit Posts though, it all goes downhill quickly.

    in the Add Post page there is simply no post editing box.

    on the left of the screen there is still the navigation bar for wordpress (dashboard, posts, media, etc.). on the right of the screen is the “publish” box, post tags, categories, etc.

    in the center of the screen, where the post editor should appear there is simply nothing. at the top it says “Add New Post” and immediately below that, where i should be able to type a new post, it’s simply blank. there is nothing there.

    also of note, in this screen the tabs “screen options” and “help” don’t drop down when clicked. in all other areas of the dashboard both of those tabs work.

    please help.

    as a last ditch effort i uninstalled literally everything to do with wordpress from my site (via FTP). i created a new mysql database (v5.0) and restored my old database to this new mysql database. then i reinstalled wordpress (again via FTP) and started over with a clean slate. if you check my site ( you’ll see that it’s all of my content but in a completely generic/default layout.

Viewing 15 replies - 1 through 15 (of 18 total)
  • esmi


    Forum Moderator

    The chances are that it was a bad plugin or 2 that was causing your problems. Try re-installing and activating your old theme and see if that still works.

    esmi – i’ve reactivated my old theme (a theme built off of K2) – and my blog looks fine now (as it should).

    the problem persists. i am completely missing any editor for both Add Post and Edit Post. both show the titles of “Edit Post” and “Add Post” at the top of the page but i have no editor (visual or html) to work in.

    all of my plugins are deactivated (i even deleted the plugins folder and replaced it with a blank plugins folder via FTP) but i still have no editor.

    i think the problem must be within the wp_options database. is there a way that i can delete wp_options as a database and install the default? or is there a way to revert to default in the database?

    i’m going through wp_options line by line and there is one thing that stands out to me as odd…

    0 395 lighter_options a:9:{s:13:”display_icons”;i:1;s:14:”separate_menus”;i:1;s:15:”reduce_userinfo”;s:0:””;s:12:”remove_howdy”;s:0:””;s:12:”hide_submenu”;s:1:”1″;s:11:”max_plugins”;s:2:”30″;s:9:”show_zero”;s:0:””;s:9:”uninstall”;s:0:””;s:6:”folder”;s:0:””;}

    i vaguely recall using some sort of tool/plugin to change the user interface of wordpress 2.7.x to have tabs, etc. could this be it?



    Forum Moderator

    An old entry in the wp-options table shouldn’t cause any problems unless you re-install & activate that plugin. Did you have access to the editor when using the default theme? Only there’s a lot of js and ad banners in your current theme.

    no, i never have access to any editor no matter what theme i choose (and all the ads, etc., in the sidebar are loaded as widgets – mostly just simple html text)

    of note, along the left bar when i’m in the wordpress dashboard the entire menu is displayed.

    however, in this menu certain functions do not work. for instance, on each main menu heading “posts” “media” etc. the arrow that should allow you expand and collapse these menus does nothing.



    Forum Moderator

    Sounds like you’ve got 1 or more bad wp-admin or wp-includes files. Try re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress

    i’ve done that. still the same problems. i’ve completely wiped everything off of my site via FTP and have started over from scratch. the only thing that i brought over from my previous installation of wordpress was my mysql databases.

    in my mind (by process of elimination) it seems as if something in the mysql databases are causing the screw up.

    is there a way to completely reset the wp_options?

    i ask this because i’ve had this same error before (about a year ago) and the only way i found to “fix” this issue was to roll back my installation to wordpress 2.7.2. or 2.7.1 – it must be something that’s in one of the mysql databases that’s still attempting to edit the way the dashboard/editor works/appears.



    Forum Moderator

    It’s extremely difficult to reset a single table in the database. What you could do is:

    1. Export your current content using Admin/Tools.

    2. Set up a completely new db, edit wp-config.php to point to the new db and then re-run the install.

    3. Log in and check that you have full editor access again.

    4. Import your old content into the new db.

    You’ll still have the problem of re-uploading all of your post/page images but, if all goes well, that could get you up and running again.

    installing on a fresh database (without importing anything over from the old databases) has fixed the problem…. now i just need to get all of my old data ported over.

    thanks esmi – i’ll update if i have more problems. at least i can post now!

    so far the only offending database has been the term_taxonomy database… weird. everything else i’ve added back as worked fine. adding back the term_taxonomy database causes me to lose the editor again.

    it appears as if my rampant use of categories killed it? somehow?

    also, now my comments are dead. i can’t view them or make new comments on posts… but at least i can post.



    Forum Moderator

    Corrupted table, perhaps? Did you create any custom taxonomies or use any taxonomy plugins on the original blog?

    all of my taxonomies were custom. which would apparently kill the editor from the dashboard? absolutely crazy.

    but crap, now i delete my term_taxonomy and i can’t load it back (because my new old one breaks the install again)

    i’m assuming that once i upload a new term_taxonomy i’ll have the ability to comment again… i hope.

    ok. so it now appears i have the following problem. if the database term_taxonomy is active/loaded for my site ( i can no longer load the post editor. i can edit and create new posts as long as term_taxonomy is dropped from my databases.

    any new thoughts?

    could it be because my terms database (and consequently my terms_relationships) contain all custom categories?

    i’ll try wiping each of those databases and reverting those three databases all to the default wordpress databases and check what happens.

    EDIT – no matter what term_taxonomy is loaded (regardless of the terms or terms_relationships that is loaded or dropped) if term_taxonomy is in my databases it kills the post editor.

    i’ll try one more time starting from scratch with a new database. go through the install process for wordpress (so it sets up all the default/necessary databases) and then add back in my posts, comments, etc. via phpmyadmin.

    this has been a royal pain in the rear and i cannot understand why using custom categories would ever cause this problem.



    Forum Moderator

    Have you tried using the Tools/Import method instead of a phpmyadmin insertion? My guess is that you’re currently re-inserting something that is killing off the post editor. Importing content should (in theory) avoid this.

    i’ve reinserted all of my posts and all of my comments. for whatever reason, if i try to import my categories it kills the post editor.

    there was definitely something wrong with my wp_options database. i’ve scrapped it entirely and gone to default. it made me lose all my widgets, but at least my posts are in, my comments are back in, and i can edit and create posts again.

    thanks for all the pointers esmi.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘help – upgraded – now cannot Edit Posts or Add New Posts’ is closed to new replies.