WordPress.org

Support

Support » Installation » [Resolved] Help! Upgrade from 2.0 to 2.1.1 left me with no post or userss

[Resolved] Help! Upgrade from 2.0 to 2.1.1 left me with no post or userss

  • The database is still there and visible in mysql. The new version of WP is there and seems to work fine – but my old blog is gone. This is VERY strange because the config.php file uses the logins for the OLD DATABASE – which means the DB is working, but somehow WP 2.1.1 does not see the data from the WP 2.0.1 db.

    PLEASE HELP! The SQL file dump is over 200 mg. I have no idea how to restore my WP blog using a SQL file.

    Mike

Viewing 6 replies - 1 through 6 (of 6 total)
  • More info on this problem….

    I have tried to use the wp-admin/upgrade.php file – and it appears to “work”, and yet my original blog is still MIA.

    I am still baffled by this one… any help would be great. I have other instances of WordPress 2.1.1 running on this same server, so I know the database and php are up to date. The problem is something to do with the transition between v 2.0.1 and 2.1.1.

    More info…

    I tried to load my SQL file into a new database. I used http://www.ozerov. de/bigdump.php BigDump for the import, and it appears to have worked okay – except that WordPress does not ‘see’ the data in the database that it is supposedly using. Help!

    what do you mean by “gone”? When you try to browse to it, what happens? Blank page? Page OK but no content? Error messages?

    I tried to import the entire SQL file into a brand new db… but got the following error:

    Error at the line 423015: INSERT INTO wp1_usermeta VALUES (44537, 3525, ‘wp1_capabilities’, ‘a:1:{s:10:”subscriber”;b:1;}’);

    Query: INSERT INTO wp1_usermeta VALUES (44537, 3525, ‘wp1_capabilities’, ‘a:1:{s:10:”subscriber”;b:1;}’);

    MySQL: Duplicate entry ‘44537’ for key 1

    —————-

    Most of the db appears to have been imported – BUT – the new version of WordPress does not “recognize” the data, and I don’t see the categories, posts, comments or anything else through the WP interface.

    Can anyone help?

    Here’s what I have right now:

    http://blogwonks.com

    I finally figured out the problem. The names of the tables are set in the config.php file. The default naming convention if for the categories to be named “wp_1something…”, but the tables that I had imported had the name “wp1_1something”, and so the wp installation was not actually implementing the categories that were there.

    Case closed.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Help! Upgrade from 2.0 to 2.1.1 left me with no post or userss’ is closed to new replies.