WordPress.org

Forums

Help: Unaccessible blog after upgrading to WP3 (7 posts)

  1. michieldoetjes
    Member
    Posted 4 years ago #

    Hi!

    I was running a RC of 3.0 and wanted to upgrade to the current release. Did so manually by uploading all files to my server. After doing so, my blog (including admin) is unaccessible. I get this error:

    return false; } ?> or the database * @since 0.71 */ $wpdb = new wpdb( DB_USER, DB_PASSWORD, DB_NAME, DB_HOST ); } ?>
    Parse error: syntax error, unexpected '=' in /customers/michieldoetjes.nl/michieldoetjes.nl/httpd.www/wp-includes/l10n.php on line 518

    Help!?

  2. michieldoetjes
    Member
    Posted 4 years ago #

    Ok, so after deleting wp-content, wp-admin & renaming plugins & themes folders and uploading these again from the .zip, I can upgrade the database using /wp-admin/upgrade.php, but still get error messages trying to visit the blog or trying to access the admin:

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /customers/michieldoetjes.nl/michieldoetjes.nl/httpd.www/wp-includes/functions.php on line 3237
    
    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /customers/michieldoetjes.nl/michieldoetjes.nl/httpd.www/wp-includes/functions.php on line 3237
    
    Warning: Cannot modify header information - headers already sent by (output started at /customers/michieldoetjes.nl/michieldoetjes.nl/httpd.www/wp-includes/functions.php:3237) in /customers/michieldoetjes.nl/michieldoetjes.nl/httpd.www/wp-includes/pluggable.php on line 890

    Any ideas on what might be wrong?

  3. michieldoetjes
    Member
    Posted 4 years ago #

    Update:
    Pretty disappointed with the final release so far... :( I've solved my problems by disabling all plugins, my custom theme based on Thematic and reverting back to the TwentyTen theme.

    From my installed plugins, only 2 work properly (Contact Form 7 & Twitter for WordPress). Even Akismet is not working!

    I'll be trying to go back to 2.9.3...

  4. joeralt
    Member
    Posted 4 years ago #

    wow!! my blog has disappeared entirely after doing the automatic upgrade
    I am using thesis theme so maybe there are compatibility issues? would appreciate any help
    Josef

  5. There is no reason why WordPress 3.0 would completely delete a site. I hope you created a back up before upgrading. It would be best to restore that back up and try upgrading again, this time disabling all plugins before going through with the process.

  6. Tzaddi
    Member
    Posted 4 years ago #

    michieldoetjes, You might check this tip about that headers already sent message. It suggests checking your wp-config file:
    http://faq.wordpress.net/view.php?p=7

    Also since the other errors are referencing your wp-includes/functions.php file, I would try making sure that particular file is a new version and not one from an older version of wordpress. Maybe some files didn't properly overwrite to newer versions.

  7. joeralt
    Member
    Posted 4 years ago #

    Thank you jeffr0
    yes i have saved a backup of course and will try tomorrow what you suggest. will keep you posted how it went
    Thanks
    Josef

Topic Closed

This topic has been closed to new replies.

About this Topic