Support » Plugin: WP Statistics » Help to update to the latest version

  • Resolved admintg

    (@admintg)


    Hi! I´m still using version 12.6.3. I checked support page before any update and this topic: “Update to 12.6.4 results in fatal error with “Class ‘Vectorface\Whip\Whip” let me a little afraid to go to version 12.6.4. I don´t know how to restart php or clean cache if the same error happen to me.

    If the same error happens here, can I uninstall e install again to solve this error?

    Just let me know.

    Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Mehrshad Darzi

    (@mehrshaddarzi)

    @admintg

    Hi, Please see
    https://wordpress.org/support/topic/last-update-results-in-fatal-error-with-class-vectorfacewhipwhip/

    your server cache composer.json file for speed.Please talk your Hosting about this problem.
    for install new version you should Download last version of wp-statistics zip file and upload to your server. in wp-content folder.

    I log into WP to see that WP Statistics needs a database update. Thinking it’s safe, I do it.

    Afterwards, I see the confirmation message:

    “Please don’t close the browser window until the database operation was completed.”

    As the use of “was” is blatantly incorrect English, should I assume this is still a valid update and not a malware install?

    @thevink Good job picking up on details like that, but I wouldn’t be worried as it looks like the plugin author(s) are not native English speakers so some mistakes are to be expected.

    I’d recommend file monitoring that comes with security plugins like Sucuri as it will notify you of the updated files and their timestamps so that you can then cross reference the changed code with the plugin’s changelog and official repository.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Help to update to the latest version’ is closed to new replies.