WordPress.org

Forums

Help! Struggling w/ html (11 posts)

  1. Emily Geizer
    Member
    Posted 6 years ago #

    I am trying to change the font color of my header in the Indore theme, but am just beginning w/ tweaking html, so I'd like some clarification.

    In the stylesheet (style.css), I came to this:
    #header h1 a:link, #header h1 a:visited {
    color: #4E9258;
    text-decoration:none;

    I've highlighted the color code number that I'm wanting (a change from #fff), but it is not changing on the site.

    What else do I need to be doing? I'm hoping to change a lot of the font colors.

    Thanks,
    Owen
    Triangle Body Therapy

  2. rocketnight
    Member
    Posted 6 years ago #

    color of what? the text, background, links?

  3. whooami
    Member
    Posted 6 years ago #

    #header h1 a:link, #header h1 a:visited {
    	color: #4E9258;
    	text-decoration:none;
    }
    #header h1 a:hover, #header h1 a:active {
    	color: #990000;
    	font-weight:bold;	
    
    }

    the above 2 bits cover, among other things, the color of the big link in your header.

    the first one, this:

    color: #4E9258;

    is the color of the link if you havent clicked on it, or arent hovering over it.

    the second bit,

    color: #990000;

    is the other color, if its active or being hovered over.

    this below, is what's responsible for the color of the text in the tag line thats also in the header.

    #header .description{
    	color: #cccccc;
    	font-weight:bold;
    	font-style: normal;
    	font-family: Arial, Helvetica, sans-serif;
    	padding: 0 20px 0 0;
    }

    I was able to edit your stylesheet, and change the colors, on the fly using firefox's webdevelopers toolbar just fine.

    How are you editing the stylesheet?

  4. @mercime
    Volunteer Moderator
    Posted 6 years ago #

    I've highlighted the color code number that I'm wanting (a change from #fff), but it is not changing on the site.

    The color is set to color: #4E9258 in your stylesheet right now. So clear cache and cookies so that you can see that the color for the H1 link has indeed already changed from #fff to #4E9258

  5. Emily Geizer
    Member
    Posted 6 years ago #

    Thanks for all your feedback!

    Mercime: I've removed cookies and emptied cache in my Safari browser but my changes are still not showing up. I'd like the big text/link in my header to be green (#4E9258) rather than that light, barely visible color. I know that the stylesheet reads the changes, but the website is not showing it. Why?

    Whooami: I am able to edit the stylesheet by clicking the "Editor" link through Safari. It seems to work just fine as far as making the canges, but they are not showing up on my header on the actual site.

    Next, I'll also be changing the hover color, but assume once I figure out this glitch that it will be fairly straightforward.

    Thanks again! I so appreciate your feedback.

    Emily
    Triangle Body Therapy

  6. @mercime
    Volunteer Moderator
    Posted 6 years ago #

    I've removed cookies and emptied cache in my Safari browser but my changes are still not showing up.

    Then change your browser because I looked at your header in IE, FF, and Safari, and it's definitely showing green (#4E9258)

  7. whooami
    Member
    Posted 6 years ago #

    yah, I see that as well. I even pasted it.

  8. Emily Geizer
    Member
    Posted 6 years ago #

    Now that I have restarted my computer, everything is showing up. Thanks Mercime and Whooami for your help!

    I'm looking forward to playing around with these colors. This is so much more fun than my WordPress.com site!

    Emily

  9. whooami
    Member
    Posted 6 years ago #

    and you, have a wonderful attitude Emily :) (a breath of fresh air, to be honest!!)

  10. Emily Geizer
    Member
    Posted 6 years ago #

    Since you guys were so helpful before, maybe you have a quick solution for these issues too:

    1. I want to change the font size for just one sub-header. I imagine I do that on the actual page, rather than with the css or php.

    Do I slip it in here:
    <div style="text-align: left;"> somewhere?

    2. How come my bullets are showing up on the edit pages but not on the published pages?

    What do I need to do to get them to appear?

    Thanks,
    Emily

  11. esmi
    Forum Moderator
    Posted 6 years ago #

    1. If it's only going to be the one page, then yes - use inline style. Something like <h3 style="font-size:1.4em"> should work. If possible, always add your inline to style to the actual element that you need to re-style. Whilst throwing in an extra enclosing <div> will work, that approach tends to lead to bloated code (aka "divitis")

    2. Something in your stylesheet(s) has removed them. Look for references to 'list-style:none'.

    It's not common to remove the default list bullets without replacing them with a graphical bullet image. If that bullet image goes missing, the end result is also list items without bullets. So also keep an eye out for:

    list-style-image:url(path_to/bullet_filename);

    and check that, in each case, the file being referenced is in the right place in your theme folder.

Topic Closed

This topic has been closed to new replies.

About this Topic