Support » Installation » Help Setting it up

Help Setting it up

  • I am having problems and I seem so new @ this and you guys are going to laugh
    But I cannot seem to get this wordpress to install….I get the error
    Error establishing a database connection! This probably means that the connection information in your wp-config.php file is incorrect. Double check it and try again.
    Are you sure you have the correct user/password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    I have Yahoo as my webhost and I set up phpMyAdmin set up and I was wondering is this neccessary
    also in the config file
    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘wordpress’); // The name of the database
    define(‘DB_USER’, ‘bigboy’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘123456’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    I havent changed anything else and the defaut directory for the files on my website are ‘wordpress’
    What else can I have possibly done wrong!

Viewing 15 replies - 1 through 15 (of 16 total)
  • Have you set the User to the Database ?
    It may all be correct, but unless the database knows that User can use it, it’ll refuse the connection.
    You may need to check that the DB_NAME is correct too, but that would be shown also in the Phpmyadmin.

    That error is commonly returned when the db is unavailable. It tends not to mean you are not configured correctly. The mysql server might be down or overloaded. A second line of thought. In wp-config.php that define malarkey looks like it is set out twice. It is in fact the top one which needs editing. It is easy to do the wrong one lower down the screen. It is also necessary in mysql to define a user and then give the user permission.

    Where would that show up in phpMyAdmin
    When I log into that it says:
    MySQL 3.23.49 running on extremeinteractive.com as bigboy@localhost
    So could you please tell me what I have wrong or what to do from there…I have not set anything esle show should I or should I not

    Now correct me if I wrong but doesnt Yahoo add a prefix to the db name?

    I am not understanding what you mean when you say did yahoo add a prefix to the db name
    db…i guess stands for ‘database’ and it is listed in my site in the folder wordpress…

    did you try your username as ‘bigboy@localhost’ instead of just ‘bigboy’? don’t know if that will work, but it’s worth a shot.

    Sometimes the username and db name are prefixed with your root username in cpanel like if my root username is premrara i get a database premrara_wordpress and a username premrara_prara
    You should ask your host to be sure.

    cpanel gives u the exact code to access the database, get the username and database name from there incase it adds prefixes to them…

    I am sorry guys but it is like you guys are talking in a language you already know and I am so new so I dont even know what the database is and all of that I am trying to learn but all this stuff that people are tellign me is a lttle confusing…
    Does anyone Use yahoo as their webhost and if you use any Instant Messengers I will be willing to IM each other to get this fixed PLEASE

    ok i dont use yahoo hosting.
    tell us this:
    how does you create a database? what kind of backend support does yahoo give u??

    okay, just a quick question.. is your database named ‘wordpress’?
    it would be helpful if you could copy and paste the EXACT information given to you regarding your database name and username (minus the password of course) so we can help.

    ok I see what you guys mean now…..my localhost was suppose to say ‘mysql’….
    Now I get the page
    We’re having a little trouble selecting the proper database for WordPress.
    Are you sure it exists?
    Your database name is currently specified as wordpress. Is this correct?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?…
    I am going to look up this or can you guys tell me what it is…I am sure you know!

    you should look it up. I would think your yahoo control panel would tell you the exact name of your database, and you could see whether it is [username]_[databasename]. then stick that in your wp-config.php file and hopefully that will get everything up and running! good luck!

    Well we seem to be going in the right direction. If you are really new Notoriouz please do not stress yourself. It might take a little time and a tiny bit of learning on the job but you will be fine. Welcome to Word Press.

    Why do I see in mysql that I dont have global access….how do i configure my priveleges

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Help Setting it up’ is closed to new replies.