WordPress.org

Support

Support » Requests and Feedback » Help! Server load problems with WordPress!

Help! Server load problems with WordPress!

  • Help! I host my websites at Westhost.com, and I have been there for about 7 years. Recently, we changed 6 of our websites from different CMS into WordPress. Somce of those other websites used PHPNuke, some used MovableType, and one used a home-grown CMS. Now all 6 use WordPress

    In the last few months that I have changed all those wbesites to WordPress, I have been receiving warnings from Westhost that my websites have been using too many system resources on the server and they are threatening to shut me down! Of the 6 WordPress websites I run, 4 have received multiple warnings.

    Now, over the last few months, none of my websites have seen a dramatic rise in traffic. And, I still have one website (my largest) which gets about 50,000 page impressions a day (quite a lot for a blog), but that is NOT using WordPress and it is causing no server load problems. it is humming along fine with minimal problems to Westhost.

    The problem is WordPress. I have seen others on theis board complain about similar problems. It seems to use lots of resources when accessing the database.

    Here is a print of my logs to show where the problems lie:

    – Apache

    2 PID USER %CPU S PR NI TTY #C TIME+ COMMAND
    22725 websitename 51.6 R 25 0 ? 0 0:05.85 /usr/sbin/httpd -DHAVE_PROXY -DHAVE_ACCESS -DHAVE_ACTIONS -DHAVE_ALIAS -DHAVE_ASIS -D
    19471 websitename 5.3 R 15 0 ? 0 1:44.52 /usr/sbin/httpd -DHAVE_PROXY -DHAVE_ACCESS -DHAVE_ACTIONS -DHAVE_ALIAS -DHAVE_ASIS -D
    22908 websitename 5.1 R 22 5 pts/0 0 0:00.27 /usr/local/mysql/bin/mysqld –defaults-extra-file=/usr/local/mysql/data/my.cnf –base
    19235 websitename 4.2 R 15 0 ? 1 2:01.89 /usr/sbin/httpd -DHAVE_PROXY -DHAVE_ACCESS -DHAVE_ACTIONS -DHAVE_ALIAS -DHAVE_ASIS -D
    22906 websitename 2.6 S 21 5 pts/0 0 0:00.14 /usr/local/mysql/bin/mysqld –defaults-extra-file=/usr/local/mysql/data/my.cnf –base
    26731 websitename 0.0 R 15 0 ? 1 0:00.35 /usr/sbin/httpd -DHAVE_PROXY -DHAVE_ACCESS -DHAVE_ACTIONS -DHAVE_ALIAS -DHAVE_ASIS -D
    18795 websitename 0.0 R 20 5 pts/0 1 0:00.07 /usr/local/mysql/bin/mysqld –defaults-extra-file=/usr/local/mysql/data/my.cnf –base
    18749 websitename 0.0 S 17 0 pts/0 0 0:00.03 /bin/sh /usr/local/mysql/bin/mysqld_safe –datadir=/var/lib/mysql –pid-file=/var/run
    18792 websitename 0.0 S 20 5 pts/0 1 0:00.03 /usr/local/mysql/bin/mysqld –defaults-extra-file=/usr/local/mysql/data/my.cnf –base
    18794 websitename 0.0 S 20 5 pts/0 0 0:00.03 /usr/local/mysql/bin/mysqld –defaults-extra-file=/usr/local/mysql/data/my.cnf –base

    Does anyone have suggestions or is there a plan for the future to remedy this?

    tks!

Viewing 15 replies - 1 through 15 (of 27 total)
  • – if you aren’t already running WP-Cache, do.
    – if you have WP’s native ‘object cache’ enabled, disable it.
    – if you have plugins doing heavy queries or dynamic generation, need to look into them further. WP-Cache will ‘eliminate’ certain dynamicism from your site without rework..

    -d

    Ok, thank you, I just found and installed the WP-Cache plugin.

    For native object enabled, where can I find that? Is that in the wp-config.php? If so, I am using version 2.0.3, and that does not have it enabled, right? Therefore I needn’t worry about it, right?

    I will monitor this first site for a few hours and then make changes to my other blogs using WP. I appreciate your great help!

    Sorry David, you answered me here at http://wordpress.org/support/topic/52452

    but I am confused when I put it up against the info in this thread.

    Therefore, please bear with me as I try to get this straightened out–I don’t want to cause my server too much extra stress by doing the wrong thing.

    I have 2.0.3 installed. I also now have WP-Cache plugin installed and it seems to be running ok. In wp-config.php I do not have define('DISABLE_CACHE', true);.

    My question for you is this: Since I have WP-Cache running, should I add define('DISABLE_CACHE', true); to my wp-config.php, or should I just keep it the same way?

    Currently all I have is:
    define('WP_CACHE', true); //Added by WP-Cache Manager

    Thank you for clarification.

    I believe under 2.0.3, DISABLE_CACHE (which refers to the INTERNAL object cache) is needed. I think it was finally defaulted OFF in 2.0.4.

    WP_CACHE on the other hand refers to, well, WP-Cache, the plugin….

    -d

    Ok, this is what my wp-config.php looks like now after I installed WP-Cache:

    define(‘WP_CACHE’, true); //Added by WP-Cache Manager
    define(‘DB_NAME’, ‘database’); // The name of the database
    define(‘DB_USER’, ‘username’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘password’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value
    define(‘DISABLE_CACHE’, true);

    Does the above look correct?

    But my host says I am using 3.5% of the server and they need me to get down to about 2%. My blog only has about 4000 pageviews a day and I am not having these problems with my website that has 50,000 pageviews a day or with one of my old MT blogs with 3000 pageviews. I really really like WP and I want to find a solution to this.

    you are using 3.5% of the server over what time period? if you’ve turned on wp-cache (that is, you went into the options panel for it, made sure it is on, says it is caching pages, should have some count of cached pages listed…), and disabled the internal cache, your server impact should have dropped off. But, if they’re taking an aggregate over a number of dats, you only JUST installed this stuff in the past 48 hours! They need to give it another day or two at least to ‘settle in’, and make sure they take a snapshot over the course of a day and not a peak timeslice midday or something silly. 😉

    -d

    Some good stuff in this thread: http://wordpress.org/support/topic/70303?replies=49

    I am having a similar problem…don’t think it’s the number of visits on my but connections staying open. Any other ideas besides what has already been mentioned here?

    Ok, Westhost responded with this messsage to me:

    It looks like your apache server was restarted about 9.5 hours ago and since then your apache processes have produced a 4.52% CPU load. I believe this is about what it was when I first e-mailed you. Yesterday afternoon it was around 3.3%.

    I ran your home page through a web site analysis tool (http://www.websiteoptimization.com/services/analyze/) and it gave a few suggestions for reducing the amount of work that Apache has to do to serve your home page. You might check that out. The biggest problems I saw were the total size of your images and the total number of http requests that had to be made to load the page.

    When I ran my site through that page, there were many images, but I have a 95% of my images served from a dedicated ad server that is not affiliated with my VPS in any way (it’s in another country, too). Most of those HTTP requests were not to my VPS, but rather to my other dedicated server.

    The bottom of my pages now say:
    <!– Dynamic Page Served (once) in 4.338 seconds –>
    <!– Cached page served by WP-Cache –>

    So, all seems well from my end, but I’m still eating CPU. Aargh….

    Geez. Maybe they need more hamsters in that server? Have they been fed?

    Color me confused. If you’re on a VPS, then there’s no such thing as using too much server load. The VPS should be capped, and that’s that.

    If you are using 4% of the CPU in apache, I’d like to know how many pages were served up in those 9.5 hours! And is the time in apache or in PHP? (if they can tell) And is the machine properly tuned to start with, i.e., lots of ram, well sized disk/file cache? I assume that time doesn’t include SQL.

    We’d need to know a LOT more to help you beyond this point. Once you have WP-Cache in place, that generally pulls a site below the radar. So without seeing your primary site, all of the sites you host on that server, and stats for that 9.5h period for each of the sites, not sure we can be of much help. 😉

    -d

    Would this help:

    Server Version: Apache/1.3.27 (Unix) (Red-Hat/Linux) PHP/5.0.3
    Server Built: Sep 2 2003 09:16:44
    Current Time: Friday, 23-Jun-2006 17:26:05 MDT
    Restart Time: Thursday, 22-Jun-2006 23:00:44 MDT
    Parent Server Generation: 0
    Server uptime: 18 hours 25 minutes 21 seconds
    Total accesses: 9781 – Total Traffic: 27.4 MB
    CPU Usage: u1817.37 s62.62 cu.16 cs.14 – 2.84% CPU load
    .147 requests/sec – 432 B/second – 2932 B/request
    2 requests currently being processed, 2 idle servers

    Well, that shows 2.8% load, which is better. And only approx 1GB xfer over a monet, if I do some rough math correctly… And a request every 8s, which doesn’t sound high at all given that a single user could generate at least a handful of requests (meaning maybe 2 or 3 users per minute).

    I still don’t know what the CPU load is really coming from. But even with 3% load, they could have 30 other users working as heavily as you, and still not start over-taxing the server necessarily…

    -d

    are you on a VPN or shared host? I am surprised to hear that even a site with 50k page views doesnt get banned on a shared host!

    alemcherry1: I am on a VPS (virtual private server). This blog only has about 4000 page views a day. When I talked before about one of my swebsites having 50,000 pageviews, that is also on a VPS at Westhost, but it is not using WordPress and it hardly uses any server resources (though it eats lots of bandwidth).

    Now it shows:

    Server Version: Apache/1.3.27 (Unix) (Red-Hat/Linux) PHP/5.0.3
    Server Built: Sep 2 2003 09:16:44
    Current Time: Saturday, 24-Jun-2006 16:48:32 MDT
    Restart Time: Thursday, 22-Jun-2006 23:00:44 MDT
    Parent Server Generation: 0
    Server uptime: 1 day 17 hours 47 minutes 48 seconds
    Total accesses: 20484 - Total Traffic: 45.8 MB
    CPU Usage: u3268.24 s109.06 cu.2 cs.16 - 2.24% CPU load
    .136 requests/sec - 318 B/second - 2342 B/request
    1 requests currently being processed, 1 idle servers

    So now I am only on 2.24% CPU load, though yesterday when I checked a few times I was between 2.2% and 3.1% at various times. My WP-Cache is working well, it seems, and here are a list of the other plugins I have:

    Customizable Post Listings 1.1
    Custom Query String 2.7
    Custom Post Templates 0.9
    WP-EMail 2.04
    Front Page Categories 0.2
    Posts Expire 1.02
    WP-Print 2.02
    WP-PostRatings 1.02
    runPHP 2.1b
    Related Posts 2.02
    wpuntexturize 0.91
    Weighted Words 1.1
    wp-cache 2.0.17

    I will continue to monitor it over the next couple of days…

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Help! Server load problems with WordPress!’ is closed to new replies.