Support » Plugins » Help, plugins deactivated because "Plugin file does not exist"

  • Hi,

    My plugins have been deactivated and have disappeared from my dashboard.

    I was trying to get a new plugin (dev-and-staging environment) installed (in WP 3.3.1). I had some issues about permissions, so I set a few directories and files to 777 temporarily (more than probably required: wp-admin; wp-content; plugins; wp-config.php). Then, the plugin seemed to install, but at the end, I got notifications about ALL my activated plugins, indicating that they were deactivated, because allegedly, the respective plugin files did not exist. And on the plugins-page, I do not see any of my plugins (neither the recently deactivated, nor the ones I had inactively for some time). I only get a notification that apparently I have no plugins installed.

    I have tried a few things, but I cannot resolve the problem. This is the current situation:

    – all plugins and their files are still in the plugins folder when I check it with an ftp-client;
    – they look fine to me, although I have no clue what I should see if they would, for example, be corrupted;
    – I have removed the dev-and-staging directory + content, but that does not help;
    – I have removed an reinstalled some other plugins, but still same result;
    – I have renamed the plugins folder to another name, then logged in to WP, then renamed the folder to ‘plugins’ again (saw that suggestion on a forum), but no result..
    – I have set the permissions on all folders and files back to what they were before.

    The site is still running fairly well, but there are some inconvenient things. For example, the mailing list sign up form (based on a plugin) has disappeared, a link to the subscription confirmation pages has popped up in the top menu (where I do not want it, probably, because of the exclude-pages plugin is inactive..), etc.

    What could be wrong and how can I solve it? (Please note I am not too familiar with the technical / coding things in WP..)


  • The topic ‘Help, plugins deactivated because "Plugin file does not exist"’ is closed to new replies.