Support » Fixing WordPress » Help Pls – sudden loss of Preview for scheduled posts

  • I’ve hunted and searched and scoured for a solution to this and found many for similar (but not identical) problems from v2.5.0 & 2.5.1, however I’m running v2.6.5 and it worked well for two months until it went “funky” last night.

    Last night WP almost had me leaping off a high balcony – I was configuring the home page and category pages for an install of eShop when it suddenly started behaving weird – example –

    I created 3 pages (example names)
    – Home (parent)
    – – Category (Child)
    – – – Product (Grandchild)
    upon saving Grandchild, the manage pages list showed their relation ship had been changed to
    – Home
    – Category
    – – Product
    OK, (growl) open Category and make its parent back to Home, it then went to
    – Home
    – – Category
    – Product
    And so it went on for hours. All the pages are unpublished right now as the eShop is not fully populated or configured. Eventually I simply thought “Botox to it” and went to bed leaving it incomplete, figuring it was something to do with category depth of unpublished pages (I already have a 4-level deep hierarchy of published pages and that is behaving itself).

    So today, there I am, happily blogging away, writing, saving, previewing all hunky dory. then scheduling and publishing for future visibility. I put up around 8 posts for over the weekend, but the last one I needed to preview to make sure an images array was displaying correctly (i.e. layout).

    Imagine my horror, when from the published successfully link pair, I click “view your post” and it returns a “Nothing Found” error for the post content, but header, footer, and sidebar is not there.

    A quick check in admin with the back button pulls up the post in full for editing (phew #1 – copy html to notepad sharpish), a quick check in the database confirms the post is there (phew #2 and growl #1 – along with 20+ draft versions … no wonder my hosts are muttering like mad things – my total blogging output is around 25,000 words per day – multiply that by umpteen saved drafts and that’s a lot of database bytes). Checked the folders and files and all the images were in Monday-coming’s date folder in wp-content (phew #3).

    So the post is there in the database, accessible from admin, and its images are on the server. But it refuses to show in preview using any variant of URL discussed in the dozens of posts from other users who had similar problems with v2.5.x – to which no WP developer ever responded as far as I can tell.

    To recap –
    – It’s WP2.6.5 and has been for two months
    – It worked perfectly until my last post this afternoon – just went mammaries upwards all of a sudden
    – the eShop plugin has been installed & configured in test mode for about 2 weeks without affecting anything
    – Creating pages (not posts) for eShop last night went haywire about half way through creating and saving unpublished pages.
    – Creating, saving and previewing posts (not pages) worked fine most of today (Bangkok time zone) and went “off” on about the 8th post.
    – previewing a scheduled and published post returns a blank post <div> with title “Nothing Found”
    – The post elements are physically saved to drive and database
    – none of the other reports of similar behaviour are for v 2.6.5 – only for v2.5.x and 2.7.x with very different fixes between those two versions.

    Installation is in /home/blog/
    Server is Linux/Apache with php5.x and MySql 5.x hosted by NameCheap
    Browsers tested are latest FireFox and IE6.5
    Local OS is Windows 2000 Server using 2MB Broadband

    Everything else on the site & hosting works perfectly, just those two problems – unpublished pages self-change hierarchical order, and scheduled published posts will not preview.


    On any given day I can be launching up to 20 scheduled posts as far as 6 months ahead (on just this one blog out of many) – I NEED preview capability.


Viewing 1 replies (of 1 total)

    Imagine my horror, when from the published successfully link pair, I click “view your post” and it returns a “Nothing Found” error for the post content, but header, footer, and sidebar is <s>not</s> there.

    i.e. – everything was there except the post content

Viewing 1 replies (of 1 total)
  • The topic ‘Help Pls – sudden loss of Preview for scheduled posts’ is closed to new replies.