Support » Fixing WordPress » Help Please – Site Stopped Working: Parse error: syntax error, unexpected '}'

  • Resolved VomCom


    My blog was working fine last I checked (let’s say about 1 week ago), then a couple days ago I can’t even log on to it anymore. Here’s the message I get:

    Parse error: syntax error, unexpected ‘}’ in /home/content/72/4192772/html/blog/wp-content/plugins/like/tt_like_widget.php on line 729

    Here’s the address:

    And I just checked my Godaddy server and made sure I’m upgraded to the latest PHP version (5.3) on a Linux server.

    My Question: Can I just go into a file using Dreamweaver and delete some code for what appears to be a “Like” button plugin? Can I delete the whole “Like” folder in wp-plugins if I find it? or would that exacerbate the problem?

    I can’t login or navigate at all, so I’m wondering what exactly to do.

    Thank you anyone who can help.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You will need to go in by FTP and delete the folder. It can be found in your wp-content folder under under plugins and is called “like”. You can delete it, and then you should be able to log in. I wouldn’t reinstall that same plugin unless the plugin has just been updated. While you’re on the page for that plugin, there’s a link to the forum for that plugin where you can post the error so that the developer can fix it. ‘twould be courteous. You can shorten the error you got to just everything after /wp-content.

    Okay, so I went in and deleted the curly brace in the “Like” plugin folder that was creating a parsing error (I know nothing about PHP, so…).

    Now I get THIS error message:

    Parse error: syntax error, unexpected ‘)’ in /home/content/72/4192772/html/blog/wp-content/themes/platform/sections/wp/section.content.php on line 41

    and here’s what that file looks like:

    (starting at line 39)

    End of section class
    */DMIN_ICONS . '/document.png'
    	   parent::__construct($name, $id, $settings);
       function section_template() {
    		// included in theme root for easy editing.
    		get_template_part( 'template.content' );
    	End of section class

    Anyone know what to do about this? Please advise.

    Thanks for the info, Matthew. I would go post for that plugin, but I’m starting to wonder if this is a more systemic problem? Seems like all the sudden, all syntax is super critical, since I’m getting these other errors on my theme and such? Any suggestion on what to do to get my blog back up?


    Easiest way would be the classic bring everything down and then bring them up one at a time. What you want to do is start by deleting the platform theme (download to your computer if it has been customized) then try logging in. If it works, try a fresh install of platform. (I suspect you have a theme issue, but we don’t have enough data yet to tell for sure.) If not, then rename your whole plugins theme to plugins.hold. This will effectively allow you to reset all plugins and the theme. If the problem is one of the plugins, then you can move them one at a time into the plugins folder (which you may have to create) and activate them in wordpress, thus isolating the problem.
    With no plugins, and the trouble theme deleted, if you still can’t get in, let us know. I would be out of ideas, but I bet someone else could help.

    I’ll try what you’ve laid out tomorrow night (too tired tonight!). I also tweeted the Pagelines Platform team with this forum’s url address to see if they have seen a lot of this lately.

    Thanks Matthew! Appreciate your help.

    I got it to start working again after deleting the “Platform” theme via FTP (using Adobe “DreamWeaver”). Of course, I had to go back through and remember to reinstall the plugins I used before, as WP uninstalled them all for some reason. But most of their settings were automatically remembered (not sure how that works). Now if this could just stop happening every 6 months or so, that would be great.

    Thanks for the help Matthew!

    Did you do the step about renaming the plugins folder, and if you did, did you follow the directions about moving them back into the plugins folder? You shouldn’t have had to reinstall them if you did.

    I downloaded all the plugin folders to my local computer, then deleted them all from the server. But when I would move a folder back to the server from my local machine, they didn’t just “appear” or install. So I had to re-search for them all, install them through the WP Admin Plugin tab.

    Still, for some reason that I don’t understand, usually most of my info and settings were auto-populated after re-installing the plugins, even though their folders should have been new and clean installs.

    Am I missing something that would’ve made this easier?

    When you moved them back, did you create a folder called plugins and then move them into it, or did you put the loose plugin folders straight into wp-content?

    As for keeping the settings, all settings for sites and themes are stored safely in the database along with the contents of all posts, pages, and comments. The files and folders you see control what gets displayed from the database, where it sits on the page, and how it is styled. An interesting side effect of this method is that if you make a copy of a theme or a child theme, it will inherit all settings from the original… unless you know how to tweak the php to give it it’s own namespace.

    I never deleted the folder named “plugins”. I just deleted all the subfolders (individual plugin folders) from the server when WP uninstalled them all — and after backing them up to my local machine.

    I’m not sure why they don’t just reinstall when I upload them back to the server (if that’s how they’ve worked in your experience?), but it’s never been that easy for me, and this isn’t the first time I’ve tried doing that.

    Strange. I’ve never used dream weaver for ftp, so perhaps that has something to do with it. Should have worked. I use filezilla.

    Could be… Next time (hopefully there is no “next time”, but…) I’ll try to remember this and use the GoDaddy ftp service.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Help Please – Site Stopped Working: Parse error: syntax error, unexpected '}'’ is closed to new replies.