Support » Theme: Hueman » HELP PLEASE! I can’t figure out how to get blog posts on the home page!

  • Hello!

    I just launched my new blog. I thought I had everything set and I published it. However, my latest blog posts are not showing on the home page under the slider image I have. Right now, I only have one published post and it’s only showing on my Blog Page. I would like to show about 5-10 posts on the home page as well.

    Can someone help me?

    Thanks!

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Out of interest, what category did you set on the post?

    Ah! It looks as though you have the static page option set, see here

    https://gyazo.com/0df99db1e0e7613709126bc5721d2773

    Make sure it shows latest posts! 🙂

    Thank you, but when I change that, it gets rid of the slider image I have on the home page, and then it also removed the blog posts from the Blog page.

    This post is under the Category “Travel Tips + Tricks”. Does Category matter?

    Thanks for the help!

    I just read that WordPress doesn’t allow you to post blog posts to a Blog Page AND the Front Page, is this true? I don’t understand that, as this blog previously did just that, before I let the hosting plan expire and lost everything 🙁

    If that’s the case, I am assuming that I need to delete the BLOG page from my menu and just have posts go to the Front Page? If I categorize them, can I still have a drop down on my menu with the Categories and will each post go there instead? Guess I’ll try that option now :-/

    Okay, so I answered my own question. It worked assigning my latest posts to the Front Page and then having a drop down of Categories to list the individual posts instead of a true Blog page.

    Last remaining question though, my Slider I have on the front page is no longer showing. Any ideas on that one? I have it inserted under Pages, on the Home page. I am using the MetaSlider plugin for this.

    Thanks!

    I’m no expert Shannon, I do place my questions here as well but most of the times I find the cure before getting an answer. Unless someone suggest otherwise, I would contact the folks at the MetaSlider support page. I’m using Hueman almost to its maximum and I love this theme. Can’t believe is loaded with goodies for a free version (www.mkreview.com).

    Nice Blog you have there, I used to Blog about Puerto Rico many years ago.

    Thanks @eltaino. I am going to post under the MetaSlide support pages as well b/c I still can’t see to figure it out. It seems, from what I’ve read, you need to have a page assigned to the front page for it to work, and you can’t do that if you have it assigned to latest posts. Hmmmm…

    You’ve got quite a nice website yourself. Would you mind if I sent you a message about some of the plugins you use (I’m assuming they are plugins)?

    ElTaino

    (@eltaino)

    Hello @shannonelizabeth. Sorry I missed your comment. For some reason I’m not receiving email notifications from replies posted on these help forums. Even when I’m the author of the question I don’t receive them. So having that in mind, please feel free to contact me with your plugin questions (info@modelkitsreview.com).

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘HELP PLEASE! I can’t figure out how to get blog posts on the home page!’ is closed to new replies.