WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Help! Parse Error

[Resolved] Help! Parse Error

  • In attempting to implement a dynamic sidebar on my blog so I can use the widget plugin, I get a strange parse error on line 90. Line 90 isn’t even a line near the code to make the sidebar dynamic, but when I take that code out, the site works again. Can anyone help please?

Viewing 5 replies - 1 through 5 (of 5 total)
  • nop we cant 🙂

    sorry

    good luck for you when at least u past the code 😉

    Chris_K
    Member

    @handysolo

    If you’d like to toss your code in a pastebin (one is http://wordpress.pastebin.ca/) and then give us a link, someone could take a link.

    A link to the site in question may be helpful too.

    so sorry, new to wordpress. here’s the code.

    function.php also contains the code:

    <?php
    if ( function_exists('register_sidebar') )
    register_sidebar();
    ?>

    thanks for the help!

    Samuel Wood (Otto)
    WordPress.org Tech Dude

    @otto42

    Between line 83 and 84, just before the </div>, add this:
    <?php endif; ?>

    The reason is this bit of code:
    <?php if ( !function_exists('dynamic_sidebar')
    || !dynamic_sidebar() ) : ?>

    That is basically saying to display the widget sidebar if it’s enabled, but if it’s not, display the following default sidebar code instead. You need the endif to tell it where the end of the default sidebar code is.

    thanks otto, that worked. check out the blog

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Help! Parse Error’ is closed to new replies.