WordPress.org

Forums

Help! No WYSIWYG Editor since 1.5.2! (15 posts)

  1. chrisfiddes
    Member
    Posted 9 years ago #

    Help! I need somebody! Help! Not just anybody...

    I've been upgrading my WordPress core with every new beta release since Strayhorn, but the rich text (WYSIWYG) editor has never appeared. It wasn't even until RC2 that the QuickTags appeared again (since Strayhorn)! I have JavaScript enabled and the 'rich text editor' box checked in my user profile and on the Options->Writing page, but still nothing! Can someone please help me?

    I've created a contributor account with the following details so someone can get a better idea of my problem:
    Address: http://chrisfiddes.com/wp-login.php
    Username: iluvwp
    Password: wysiwyg

    I didn't realize what I was missing until I looked at the post writing page on my wordpress.com account. That kind of text editor is just what I had been dreaming of for my blog. Thanks for any help!

  2. hallsey
    Member
    Posted 9 years ago #

    Dunno what to tell you. I logged in and, except for the differences in the theme, I got the same I get at home. I see the editing box and the quicktags. Is there supposed to be more? Maybe I should lodge a complaint with the management too! :)

  3. vkaryl
    Member
    Posted 9 years ago #

    Hmmm. Are you using some browser other than "mainstream PC" ones?

  4. chrisfiddes
    Member
    Posted 9 years ago #

    @hallsey: Yes, there should be more than just quicktags because the rich text editor is enabled but the WYSIWYG editor does not appear.

    @vkaryl: I'm using Firefox, and I have the same problem in IE.

    The WYSIWYG editor that should appear when 'rich text editor' is enabled is the same as the one available at wordpress.com, right? That's what won't show for me. Thanks for the input guys!

  5. Kafkaesqui

    Posted 9 years ago #

    Sounds like you're lacking the js directory (or at least some part of the tinymce stuff) under /wp-includes.

  6. hallsey
    Member
    Posted 9 years ago #

    Out of the box, so to speak, WordPress 1.5 has no directories under /wp-includes.

  7. Kafkaesqui

    Posted 9 years ago #

    From the OP:
    "I've been upgrading my WordPress core with every new beta release since Strayhorn, but the rich text (WYSIWYG) editor has never appeared."

    This is a 2.0 issue.

  8. hallsey
    Member
    Posted 9 years ago #

    Oops, thanks for the clarification!

  9. Kassad
    Member
    Posted 9 years ago #

    Upgrading with betas many times may cause many troubles.
    Try a virgin install.

  10. chrisfiddes
    Member
    Posted 9 years ago #

    @Kafkaesqui: How can a stable 2.0 release come so soon if this is still an issue?

    I've seen the WYSIWYG editor working at wordpress.com, so surely they've got it working already...

  11. Kafkaesqui

    Posted 9 years ago #

    How can a stable 2.0 release come so soon if this is still an issue?

    I'm using 2.0 on three different sites without seeing this, and I don't see others reporting a problem as you have here.

  12. vkaryl
    Member
    Posted 9 years ago #

    I've got 2.0 beta 1 running on a site, the stupid wysiwyg shows up just fine. Not sure why you're having a problem with it.... and I'm not going elsewhere....

  13. Turk
    Member
    Posted 9 years ago #

    I had the same problem as the op. I had been running a back up of my database and it started a few versions ago. I didn't keep track of it since I disable the WYSIWYG editor by default.

    I just did a fresh install with an empty database and the WYSIWYG editor was back. I'll play around with it at work to see if it was a plug in that interfered.

  14. chrisfiddes
    Member
    Posted 9 years ago #

    My goal is to have this site up and running properly by 2006, so I'll try disabling some plugins to see if it's a plugin conflict. If nothing else, I'll reinstall WP 2.0 final from scratch when it's released. I'll report back here with what I find.

  15. Turk
    Member
    Posted 9 years ago #

    I tried that. I have yet to figure out what plugins do whatever it is that happens. But I did the fresh install and started turning on the same plugins as on my live site. Same thing happened. the WYSIWYG editor stopped showing up.

    Ok for me it was the Admin menu. As soon as it turn on it makes the WYSIWYG editor revert back to the standard editor. I'm going to make sure I have the latest version installed to be sure.

    I do have the latest version of that plugin and it is doing it for me. Hopefully this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags