[resolved] Help, Newbie 403 Problem (6 posts)

  1. reki
    Posted 9 years ago #

    Hello. I'm running an apache server on my own computer with PHP 5 installed. I followed all of the installation instructions and when I went to install.php, I recieved the 403 Forbiden error. I looked through as many help posts as I could and I couldn't understand the Installation FAQ's solution. Can someon please help me. This problem is driving me crazy.

  2. ptvguy
    Posted 9 years ago #

    Go back to the phpMyAdmin and make sure that you've already set up a mySQL database for WordPress and created a user for it with appropriate permissions to access and modify it. Then make sure that you have modified the wp-config.php file appropriately:

    define('DB_NAME', 'YOURDATABASENAMEHERE'); // The name of the database
    define('DB_USER', 'YOURDATABASEUSERNAMEHERE'); // Your MySQL username
    define('DB_PASSWORD', 'YOURDATABASEPASSWORDHERE'); // ...and password

  3. reki
    Posted 9 years ago #

    I have no idea what "phpMyAdmin" is but I did configure the wp-config.php file properly.

  4. reki
    Posted 9 years ago #

    Sorry, Double Post:
    Uh, yeah, I just found out what phpMyAdmin is. I tried running it in my local server and it gave me the 403 error (what a surprise). Abyway, I added the SQL server and user with MySQL Administrator and MySQL Query Browser. BTW, this is what my 403 Error looks like:

    You don't have permission to access /php/php-cgi.exe/brog/index.php on this server.

    Yes, I named the file where I'm keeping the wordpress stuff "brog". It was a typo at first but it stood, so yes, its a real location on my server.

  5. reki
    Posted 9 years ago #

    OH FINALLY, I found the solution. It was on an Apache4/PHP5/MySQL4 tutorial done by this German guy. In one of the comments by some of the people who visited his site, here(http://www.tanguay.at/installPhp5.php5?step=7) on the way bottom:

    "Sparkie@may2006: to get rid of the 403 forbidden error: loosen security settings in the httpd.conf by removing the lines "Order allow,deny" and " Allow from all" in the Directory-tag, which is located just below Documentroot (search on 'restrictive') Good Luck!"

    It works. Try it

  6. ptvguy
    Posted 9 years ago #

    Cool. Glad it worked out. Make sure you mark this post "resolved."

Topic Closed

This topic has been closed to new replies.

About this Topic