Support » Plugins » Help needed setting up WP-Cache

  • Resolved jimmycanuck


    I’ve tried to install the WP-Cache plugin several times in the past, and every time it has crashed my site. I’ve decided to give it one more try as I really need a solution to the speed and stability issues my site is having. I’ve set up a test version of my site at — as you can see, installation of the plugin results in the following error;

    Warning: require(/mnt/w0110/d18/s46/b029f009/www/ [function.require]: failed to open stream: No such file or directory in /mnt/w0110/d18/s46/b029f009/www/ on line 84

    Fatal error: require() [function.require]: Failed opening required ‘/mnt/w0110/d18/s46/b029f009/www/’ (include_path=’.:/usr/local/nf/php5/lib/php’) in /mnt/w0110/d18/s46/b029f009/www/ on line 84

    Unfortunately, I’m not nearly techy enough to know what to do. This shuts everything down completely, including the dashboard. Luckily I know what I need to do to remove the plugin and get the site back thanks to past attempts (it involves deleting a few lines of code). However, this time I’m determined to get this working.

    What I did was install the plugin as per usual, activated it, and went to Options>WP-Cache. Up until that point, everything is fine. After that though, it’s all about the errors.

    I’m completely at a loss for what to do. If any of you know how to solve this, it would be greatly appreciated. I’m determined, but dumb about the technical end of things.

Viewing 11 replies - 1 through 11 (of 11 total)
  • whooami



    Thanks for the quick reply whooami. 🙂

    And no, the files not there. There’s a wp-cache-config.php in that folder, but no advanced-cache.php.

    Any idea what that file is or where I can find it? Should putting that file in that folder fix the situation?




    it will help that error, yes. Thats EXACTLY what that error is telling you:

    Failed opening required '/mnt/w0110/d18/s46/b029f009/www/'

    It appears this has been discussed previously here:

    Google it:

    Sorry, I’m really not all that technical. Any idea what that file is or where I can find it?




    Read my edited post above ^

    Its also discussed on the plugin author’s page:

    Under “manual installation”:

    In case you don’t want to make wp-config.php writeable by the server, or you want to make all steps manually:

    1. Upload to your plugins folder, usually wp-content/plugins/ and unzip the file, it will create a wp-content/plugins/wp-cache/ directory.

    2. If you have Gzip Compression enabled turn it off (in Options->Reading).

    3. Create wp-content/cachedirectory and make sure the web server can write in it.

    4. Make wp-content writeable by the web server.

    5. Create a symbolic link from wp-content/advanced-cache.php to wp-content/plugins/wp-cache/wp-cache-phase1.php.

    ln -s wp-content/plugins/wp-cache/wp-cache-phase1.php wp-content/advanced-cache.php

    6. Add the following line to your wp-config.php file: define(’WP_CACHE’, true);

    7. Go to “Options” administration menu, select “WP-Cache” from the submenu and enable cache.

    The discussion that occurred here previously doesn’t get the plugin working, it just gives you the steps to get the site back online without it.

    When it comes to the manual instructions, I understand everything except #4 and #5. How do I make wp-content writable (though I assume it already is)? And what do they mean by “create a symbolic link”?

    K – scratch that last comment. I figured out what #4 and #5 meant, went through all the steps, and still having the same problem. Those steps didn’t do anything to create the missing file.

    Anyone out there know what to do?




    you didnt create the symlink — had you that link I pasted in my first reply would not still be resulting in a 404.

    creating a symlink requires that you have shell access, ie, you can ssh or telnet into your host.

    who – thanks again for the help and your patience. I’m currently in Terminal (I’m on a Mac) and I’ve logged on to my server. I had modified the line of test that I need to put in to include test/ beforehand (as I am doing this on my practice install so as not to damage my site.) The response I am getting is “test/wp-content/advanced-cache.php: No such file or directory”

    Any suggestions?

    Just a heads up for anyone who might be interested. It turns out the problem was with my hosting. I’ve had other issues (such as the speed issues that lead to my needing this in the first place) so I decided to spent the last 12 or so hours working on getting moved to a different host. Based on the glowing words most people have had about A Small Orange, I decided to go with them. Now when I attempt to install WP-Cache the site doesn’t crash, it just gives me the error message that everyone else having trouble gets. Once they give me SSH access, I should be able to get it up and running. I’ll close this ticket just as soon as I know for certain – that way I can update anyone out there who might be having a similar issue on what took place. 🙂

    That was it, it was my hosting. New host, no problems. Not to bash but if you’re with Netfirms and are having the same problem, that’s probably why.

    Hope this helps anyone out there with the same trouble! 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Help needed setting up WP-Cache’ is closed to new replies.