[resolved] HELP NEEDED PLEASE (UTF changed) (4 posts)

  1. artwerx
    Posted 6 years ago #

    I accidentally changed my UTF-8 to 7 by mistake. Since then, I'm not able to edit my blog in any way (changes won't save)

    I have tried to export my blog, delete the old one, then import the save but it only brings in some of my posts, not all and if I can remember correctly, when it brings the settings in - the whole problem comes with it.

    I need help with the following. I either need to know which files to:
    -- edit in my current 'frozen' blog to change that UTF-8 (in the actual files, as i can't use the dashboard)
    -- if I put in a fresh copy, which actual files contain the posts, comments, images, etc, BUT NOT SETTINGS

    I'm totally frozen and I need my blog to help with my art sales - PLEASE, someone help me. :)

  2. Doodlebee
    Posted 6 years ago #

    You set your encoding in the Settings page, under Reading. If you can't access your Admin area then you have to edit it from the database. Get into phpMyAdmin, go to the wp-options table, and change the "blog_charset" to "UTF-8".

    If it worked before, and the accidental change is what cause your issues, then the problem isn't in your theme files - it's in your settings. If you have a backup of your database (and can't get into phpMyAdmin" you could also search for "blog_charset" in the .sql file and change the setting to the correct one, then import the fixed file.

  3. artwerx
    Posted 6 years ago #

    THANK YOU SO MUCH - since I couldn't edit the settings normally, I was able to do that in phpMyAdmin. I just learned a very useful thing!

    You saved me :)

  4. Doodlebee
    Posted 6 years ago #

    Good - glad you got it sorted :)

Topic Closed

This topic has been closed to new replies.

About this Topic