Support » Installing WordPress » Help needed in installing WordPress on Virtualmin

  • Hello,

    I got a VPS with CentOS 5.7 on it. I’ve asked the hosting people to give me VirtualMin as it is free.

    I tried several ways to install WordPress on it but i can’t get the work done. I came across a lot of tutorials on the net and tried them but it isn’t helping !

    Finally i am getting this message when i try to install WP
    “Your PHP installation appears to be missing the MySQL extension which is required by WordPress.”

    But i have the MySQL installed. Can anyone help me out with Installing WP on VirtualMin/Webmin

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hi ChristiNi,

    Those threads are helpful to me. I tried some steps from them but now problem is redirected to PHP

    I am getting PHP missing on the install.php even when it is installed on the VPS

    Can you suggest any remedy on that

    These are the websites that we are trying to get installed

    Both give me the same error !

    kind of bumping into similar problem… Error:PHP is not running

    See if someone may help. Thanks a lot.

    Hi sameermanas,

    It appears PHP is not configured correctly to execute the PHP files. You may want to contact the hosting provider to see if they can help you.

    Hi Tim,

    I tried contacting them numerous times but they aren’t so good at responding to customer problems.

    The blogs are to be installed on a VPS with CentOS on it. I tried restarting the apache server but that didn’t help me either !

    I don’t understand what steps i need to take further.

    Hi sameermanas,

    Can you try creating and uploading a phpinfo.php page? If you’re not familiar with that, here’s the instructions:

    If the phpinfo page loads, then PHP is at least being executed by your server.

    Let me know what happens with the phpinfo page.

    Hi ChristiNi,

    I tried the tutorial and created a file but it is just displaying the content of the file as <? phpinfo(); ?>

    Also all the files in the WordPress directory are showing up with the content.

    I tried 755 on all directories and 644 on all files but still i get plain text when i go for

    here is the file i made with phpinfo

    What does it indicate ? PHP running or stopped ?


    From a console, or if you are using webmin, open the interface; Menu > Others > Command shell, and Execute command: rpm -qa | grep php

    What is the response?

    Hi Clayton,

    Here is the out put and i use Webmin


    Hello again ClaytonJames,

    I’m sorry you’re still dealing with this issue. One last thing you can try is checking your document root for each domain for an .htaccess file. I you do have an .htaccess file for one or both domains, try renaming the .htaccess file to disable it. If your issue is still unresolved, your host really should be looking into this for you. It could be as simple as PHP not being added to your server’s configuration file, but this is something your host really should have set up for you.

    Good luck and hope this helps!



    Forum Moderator

    @christini: <*cough*> Clayton is a forum regular & something of an expert on server-related issues.<*cough*>

    So sorry! I addressed my last post to the wrong person, that was intended for sameermanas. Thank you for pointing that out esmi. Please pardon my mistalke Clayton!


    No problem!


    In reality, I’m just a “let’s break all the things!” kind of guy. But I have fun trying. 🙂


    Are those php53 packages from the Atomic repo? I’ve never used them myself, (I’m sticking with php 5.2.10 from the testing repo for the time being) so I don’t have any point of reference for possible issues if they replace core packages, but I don’t think I see anything telling in the output.

    Take a look inside of /etc/httpd/conf.d/php.conf

    …are these lines all (present and) uncommented?

    LoadModule php5_module modules/
    AddHandler php5-script .php
    AddType text/html .php
    DirectoryIndex index.php

    Hi Clayton,

    Those lines are all commented and also there exist another php.conf.rpmsave

    I came across a CentOS forum where i came to know that Atomic repo would be updating things by itself and everything would be automated. So i added that to the rep’s. Do you think that is causing the issue ??

    Here is the content of the php.conf

    # PHP is an HTML-embedded scripting language which attempts to make it
    # easy for developers to write dynamically generated webpages.
    <IfModule prefork.c>
      LoadModule php5_module modules/
    <IfModule worker.c>
      LoadModule php5_module modules/
    # Cause the PHP interpreter to handle files with a .php extension.
    AddHandler php5-script .php
    AddType text/html .php
    # Add index.php to the list of files that will be served as directory
    # indexes.
    DirectoryIndex index.php
    # Uncomment the following line to allow PHP to pretty-print .phps
    # files as PHP source code:
    #AddType application/x-httpd-php-source .phps

    Is it better to remove the comments or anything i should change ?
    If anyone can help me out i wouldn’t mind giving my credentials to the VPS.

    @sameermanas, Update:

    Well, I must say you certainly piqued my curiosity. Just for giggles, I loaded a fresh snapshot of 5.7 with the default httpd, MySQL (5.0) and PHP (5.1) configurations, and then installed virtualmin/webmin. I plopped a phpinfo file in the /html directory and it worked as expected. Next I activated the Atomic repo and ran a yum upgrade. This bumped my versions of MySQL and PHP to 5.5.18 and 5.3.8 respectively. I think this is probably what has been done on your server as well. I did a quick “service httpd restart” and then rechecked the phpinfo file. Still working as expected. The output of “rpm -qa | grep php” on my server is now almost identical to yours, with the exception of having no duplicate entries. I honestly don’t know if that is a significant clue or not.

    I think at this point, if everything in /etc/httpd/conf.d/php.conf looks okay, you may want to put in a service call to your host as ChristiNi suggested. As slow as that might seem to be, they might be able to quickly point you to a solution. I’m sorry I couldn’t duplicate the issue and offer a solution, but I had fun trying!

    [edit] your php.conf is identical to mine.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Help needed in installing WordPress on Virtualmin’ is closed to new replies.