Support » Plugins and Hacks » NextGEN Gallery » [Resolved] Help needed!- Page hangs at "Select or enter gallery"

[Resolved] Help needed!- Page hangs at "Select or enter gallery"

  • Hi!,

    When trying to add an existing “NextGEN Gallery” to a page, I can click the “Add NextGEN Gallery” button and the window comes up that allows you to select the gallery to add.

    Clicking “Select or enter gallery” within the Gallery tab, “Select or enter album” in the Album tab, or “Select or enter picture” in the picture ,the swirling circle comes up, starts circling but nothing happens.

    For those who don’t uderstand what I mean, have a look at the instruction video:

    My Problem is @ 2:50, where I can’t select one( swirling circle comes up)

    NextGEN Gallery version is 1.9.7

    Thanks for help!


Viewing 15 replies - 1 through 15 (of 23 total)
  • I don’t know why it isn’t loading properly so I can’t help there but here is a work-around.

    Why not just add the code to the page where you want the gallery to display. It’s pretty simple code. On mine it looks like this

    [nggallery id=9]

    Try pasting this code into your page or post and change the number to reflect the actual number of the gallery you want to display. You don’t have to add it to the HTML editor… you can paste it right into the WYSIWYG editor. Sorry I can’t be more help.

    Thanks for the fast help!

    Your code is working. At least I will be able to post a gallery 🙂


    I just wanted to note that I am also experiencing this problem on a website I just built. Through a little testing, I found that the ‘NextGen Gallery Plugin’ appears to be conflicted with the ‘Restricted Site Access Plugin’.

    If I disable ‘Restricted Site Access’, the dropdown loads properly and I can select an image, gallery or album when creating a post or page. But, with ‘Restricted Site Access’ enabled, the dropdown never loads, even though I am logged in to the site as an Administrator.

    Are you by chance running the same plugin? If not, I wonder what is actually causing the conflict.

    Experiencing same problem on two different sites (one site running Twenty Eleven theme and very few plugins) since upgrade to latest version (1.9.8)

    I’ll use the workaround proposed, at the moment I don’t have time for testing. Thanks!

    Are you by chance running the same plugin?

    No, tried running wordpres with only NextGen Gallery installed (no other plugin) but problem was still there.

    since upgrade to latest version (1.9.8)

    Same scenario for me, was working until I did an update of wordpress and NextGen to the latest version.

    HELP! I am trying to use the plug in and I get stuck at the same screen. I understand about the work around, but can we not fix the plug in? I’m trying to show someone how to use WP on their site and it’s frustrating for this most popular plug in on the planet not to work isn’t it?

    Please send help.

    Same problem. Would live to be able to fix it

    Same issue as I cannot access the Short Code in order to insert gallery into my posts. However, I am using NextGen Version 1.9.3 – I have not upgraded to 1.9.8, but I did upgrade to WP 3.5 yesterday and that is when it started.

    I am not running the ‘Restricted Site Access Plugin’ either.

    I tried IE, Mozilla and Safari and all were the same.

    Yes, the workarounds are fine but it is a waste of time. If anyone has the answer please let us know. Has anyone gotten ahold of Alex Rabe? It seems like alot of us are having the same issue and there will be more as they upgrade to WP 3.5.

    Well I found out what my problem is. It may help you too. I use an awesome theme called Weaver II. It is a responsive theme that delivers customized mobile views automatically. It’s using responsive code. Nextgen Gallery uses non responsive code. Sooooooooo. My loyalty lies with the theme so I’m going to use a different gallery app or maybe even the native one. Maybe someday I can use Nextgen if they update their code.

    Plugin Author photocrati


    Could everyone who is currently experiencing this error provide all of the following information?

    WordPress up to date?
    NextGEN up to date?

    (please confirm the following, with your server host tech) :
    MySQL up to date (5.2.4)?
    PHP up to date (5.0)?
    The mod_rewrite Apache module activated?
    PHP Safe Mode OFF?

    and if you’re willing to share:
    Who are you hosted with?
    What theme are you running?
    Which plugins do you have installed and activated?
    Does this error still occur if you switch your theme to the WP default, and deactivate all plugins except NextGEN Gallery? (*be sure to clear your browser cache and reload your site after deactivating)

    *Please also provide the steps you took to see the error. Thanks!

    I’m having the same problem. I ended up using the shortcode HOWEVER when i pass this over to my client that’s not really going to be an option for them.

    In response to the request for more information:
    I’ve checked all the items listed and we are up to date on all software.
    I checked with weaver theme.com. They have a forum thread pertaining to this. It says that since Weaver II is written in reactive code and NextGen is not, they are not compatible. Since I use Weaver for all my sites, it would be awesome if NextGen can be updated. It really is a great application, but I can’t go back and redesign all my sites so I can use it. 😉

    Thanks for taking time and acting on this!

    In response to the questions, yes everything is up to date also.

    Having this problem on multiple sites using NGG 1.9.8 (not on sites using 1.9.7, so I have started skipping that upgrade).

    One site having problem, we’re running WP 3.4.2 and the twenty eleven theme.
    Hosted by GreenGeeks
    Host is running PHP 5.3.19 and My SQL 5.1.65
    Mod_rewrite is enabled
    PHP safe mode is on but given that we have multiple sites running well on this same hosting account, I am not going to start with changing entire hosting environment.

    Plugin list:

    Akismet, Broken Link Checker, Digg Digg, Google Analyticator, Google Doc Embedder, Next Gen Gallery, Simple Notices, WuFoo shortcode pulgin, XCloner

    Description of problem:

    When in the rich-text editor and attempting to “insert a Next Gen Gallery” using the editor button, the small window opens and the dropdown menu that allows the user to select a gallery displays a circle “wait” icon. But the list never populates. I can insert a gallery using shortcode only in the editor.

    Thanks for any attention you can give this!

    Plugin Author photocrati


    Hey everyone,

    We just released v1.9.10 that should resolve this error.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] Help needed!- Page hangs at "Select or enter gallery"’ is closed to new replies.