WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Help, my blog is all blank (not covered in previous support).

[Resolved] Help, my blog is all blank (not covered in previous support).

Viewing 15 replies - 1 through 15 (of 24 total)
  • The host says they did not make any changes after migrating the site to the new server (it worked for 3 days after the migration), so it’s not caused by them, they say.

    blank pages happen a lot when the theme gets messed up.
    Though I didn’t read all the examples you listed, have you tried removing your existing theme folder (renaming might work too). I know if you remove your theme folder it will default to the “default” theme.

    That’s assuming it is a theme problem.
    May be worth a shot.

    In response to brockangelo, I moved the existing theme’s folder (even though I had not made recent theme changes), but it made no difference.
    Thanks anyway for the suggestion.

    Hm – this is probably over my head then. I guess it is possible that your database is still pointing to a location on the old server. They may have copied your database to the new server, then waited a few days to delete the old. If so, that would explain it.

    By old location I mean something like:

    /usr/local/psa/home/vhosts/brockangelo.com/httpdoc…

    as seen in wp_options

    In cPanel’s MySQL section, I “checked” the wrdp1 database – all tables were OK, but several had warnings of being either in use or not properly closed previously. I clicked repair, and now all are OK, with no warnings. But the problem remains.

    I checked the ERROR LOG:

    PHP Fatal error: Allowed memory size of 12582912 bytes exhausted (tried to allocate 582046 bytes) in /home/imageca/public_html/blog/wp-includes/cache.php on line 48

    In another support topic, someone suggested increasing the PHP memory size from 8MB to 16MB. (Another said 8MB was ample.) Here the memory size is 12 MB and only requires 0.5 MB.

    Can I DELETE cache.php?

    No, I can’t. I renamed wp-includes/cache.php, and got an error message on my home page (hey, that’s better than blank?), so I undid the renaming.

    The error log says the error occurs in:
    wp-includes/cache.php on line 48

    (This same PHP error is repeated many times – it occupies all of today’s Error Log.)

    Line 48 reads:
    $data = unserialize(serialize($data));

    It is part of this sequence:

    function wp_cache_set($key, $data, $flag = '', $expire = 0) {
    	global $wp_object_cache;
    	$data = unserialize(serialize($data));
    
    	return $wp_object_cache->set($key, $data, $flag, $expire);
    }
    
    define('CACHE_SERIAL_HEADER', "<?php\n/*");
    define('CACHE_SERIAL_FOOTER', "*/\n?".">");

    The file wp-includes\cache.php has not been changed.
    Last modified date (presumably by the WP 2.3 team) is August 13. (It’s now October 14.)

    WEIRD HALLELUJAH

    SOLUTION:

    1. Rename wp-includes\cache.php (to anything)
    2. Reload the homepage (getting an error message: missing cache.php)
    3. Restore the original name of cache.php.

    Reload – and rejoice! (Amidst mystery.)

    I suppose this is resolved, but

    I wonder why the problem occurred in the first place, and if something needs to be done so others don’t have this problem.

    Just to add a data point…I just had the exact same problem and the exact same thing “fixed” it: rename the cache.php, refresh front page (get error), name cache.php back to original name, reload…voila.

    I don’t think I was doing anything that would’ve mucked with anything major…just was changing around some tags on posts and…boom. Blog gone. Quasi heart-attack.

    Ditto.

    Sure glad I found this thread.

    did not work for me 🙁

    changed the name of cache.php to something else

    got the error

    Warning: main(/org/www/domains/dev.goldworld.it/wp-includes/cache.php) [function.main]: failed to open stream: No such file or directory in /org/www/domains/dev.goldworld.it/wp-settings.php on line 157
    
    Fatal error: main() [function.require]: Failed opening required '/org/www/domains/dev.goldworld.it/wp-includes/cache.php' (include_path='.:/usr/share/php:/usr/share/pear') in /org/www/domains/dev.goldworld.it/wp-settings.php on line 157

    changed back to cache.php

    http://dev.goldworld.it/

    🙁

    (fresh wordpress 2.3.2)

    could this be a database problem?

    I’m using a copy of the database from the live version of the website

    http://www.goldworld.it

    which is wp2.2

    update_ I’ve changed the prefix in the wp_config file and I was given the same… that should have prompted me with a fresh installation (those tables don’t exist), shouldn’t it?
    Did the rename trick and still no joy 🙁

    fabbio, did you ever get this issue solved?

    I’m having the same issue, with the same results as Fabbio. Renaming the cache.php gives me an error, but renaming it back gives me the blank blog again. I can’t load my wp-login page. Tried to upgrade to the latest version of WP, but the upgrade.php page won’t load, either. Everything is just plain BLANK.

    http://jenba.net/sims2

    Other subsections of my site work fine (http://jenba.net/gnomesby and http://jenba.net/simscribes) so I’m not sure what the problem is. I can access the site via FTP just fine.

    Before I attempted the WP upgrade, I hadn’t touched any files in that folder for months. So I hadn’t made any recent changes. Anyone have any ideas?? I’m at a loss.

    Same problem with my sites for homepage.

    Is this a flaw in WP 2.6?.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Resolved] Help, my blog is all blank (not covered in previous support).’ is closed to new replies.
Skip to toolbar