Support » Fixing WordPress » HELP! my admin functions have gone away…

  • In an attempt to get the links permissions working the way I want (nothing seemed to work), I opened up /wp-admin/menu.txt and changed the following line:
    5 link-manager.php Links
    to:
    1 link-manager.php Links
    But, now even when I log in as admin (level 10), I ONLY get the option to Post or view/edit my Profile. All other editing options (including adding/removing categories, links, blog settings, etc…) are GONE!
    I tried setting the “1” back to a “5”, but it didn’t help.
    Any ideas?
    Thanks,
    Tony

Viewing 4 replies - 1 through 4 (of 4 total)
  • Well, I’ve got my proper admin screens back (just re-downloaded 1.0.1 and copied over the wp-admin folder.)
    But, I still can’t get link-categories to work right:
    I’ve set links_minadminlevel to 1
    and links_use_adminlevels to TRUE
    No dice. A user cannot get the ability to manage links until I set them to level 5, which gives them a bunch of stuff I don’t want them to have.
    Anybody?
    -Tony

    Has anybody been successful in allowing users with a 1 or 2 admin level to create/edit links? If so, what was the trick?
    Anybody?
    Please?
    -Tony

    Two parts: having them able to do it, and having the menu item. If you set links_minadminlevel to 1, and then send a level 1 user directly to /wp-admin/link-manager.php do they get in, with the ability to add a link? That works fine for me.
    Then, to get the menu item, since it isn’t looking at the options (yet, anyway), you’re right that you have to edit menu.txt after saving a backup copy. Did you by any chance edit it in an editor that converts tabs to spaces, before? menu.php doesn’t do much error trapping, and expects there to be a tab between the level and the filename, and the filename and the label, and if there was a space or spaces instead, it looks like bad things would probably happen. But without tabs-to-spaces, changing it to a 1 gave my test lowly luser a Links menu item.

    Ok, thanks…I didn’t think it was converting tabs to spaces, but that’s what must have happened. I re-edited in emacs, and all is working fine now.
    Thanks,
    Tony

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.