WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] My 404 Page is possessed!

[Resolved] My 404 Page is possessed!

  • CWITT2013
    Member

    @cwitt2013

    I fixed the menu and such and the site is working well.

    http://www.chinalakegastro.com/rrh

    Now, when I put in a page that does not exist, my navigation menu is all bunched up in the left side instead of spread out over the page.

    Example: http://www.chinalakegastro.com/rrh/404

    Why would this page be different from the rest of the site?

    This is my 404.php:

    <?php
    /**
    * The template for displaying 404 pages (Not Found).
    *
    * @package Toolbox
    * @since Toolbox 0.1
    */

    get_header(); ?>

    <div id=”mainContent”>
    <div id=”contentpaneopen” role=”main”>

    <article id=”post-0″ class=”post error404 not-found”>
    <header class=”entry-header”>
    <h1 class=”entry-title”><?php _e( ‘Well this is somewhat embarrassing, isn’t it?’, ‘toolbox’ ); ?></h1>
    </header>

    <div class=”entry-content”>
    <p><?php _e( ‘It seems we can’t find what you’re looking for. Perhaps searching, or one of the navigation links above, can help.’, ‘toolbox’ ); ?></p>

    <?php get_search_form(); ?>
    </div><!– .entry-content –>
    </article><!– #post-0 –>

    </div><!– #content –>
    </div><!– #primary –>

    <?php get_footer(); ?>

Viewing 11 replies - 1 through 11 (of 11 total)
  • ryansantschi
    Participant

    @ryansantschi

    They currently don’t look different to me. Try clearing cache or looking using an incognito browser.

    CWITT2013
    Member

    @cwitt2013

    I am using it in Firefox and IE 8. They both show the same thing. Let me show you what I see:

    http://s48.photobucket.com/user/NewMommy310/media/404.jpg.html?sort=3&o=0

    ryansantschi
    Participant

    @ryansantschi

    🙂 that link isn’t working for me. Maybe it is a private album?

    CWITT2013
    Member

    @cwitt2013

    ryansantschi
    Participant

    @ryansantschi

    What I see with your links, is very different then what your pics show. It seems like you are using another themes css with a custom toolbox theme. Here’s your stylesheet info:

    Theme Name: Spine
    Theme URI: http://spine.paulwp.com
    Author: Paul de Wouters
    Author URI: http://paulwp.com/
    Description: Theme based on Hybrid Core and Zurb Foundation front end framework

    CWITT2013
    Member

    @cwitt2013

    The theme I am using is Toolbox. It is interesting that it comes up Spine for you….hmmmm…

    ryansantschi
    Participant

    @ryansantschi

    The theme is toolbox but the CSS sheet that is being loaded is Spine. Check out your header!

    ryansantschi
    Participant

    @ryansantschi

    <link rel="stylesheet" type="text/css" media="all" href="http://chinalakegastro.com/rrh/wp-content/themes/toolbox/style.css"> This is right. But when you click on it is shows the Spine CSS

    CWITT2013
    Member

    @cwitt2013

    Thanks for the guidance. I will give it a shot and let you know the results.

    ryansantschi
    Participant

    @ryansantschi

    Looks like the right style sheet is loaded. Here’s your problem on your style.css:

    .error404 .widget {
    float: left;
    width: 33%;
    }

    When your 404 page loads in gives the body a error404 class. In your css you have an error404 .widget class that gives a width of 33%. Remove that (the width value) and your 404 menu will look the same.

    CWITT2013
    Member

    @cwitt2013

    ryansantschi,

    THANK YOU!

    It did take a bit more tweaking. The 404.php had the page under “article id” so I changed it to div id=”error404″ and it worked PERFECT!

    I are happy now! (yes that was intentional!)

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] My 404 Page is possessed!’ is closed to new replies.