Support » Networking WordPress » HELP – Multiple problems with configuring a multisite

  • Hi here =)
    Before I begin, I want to tell you that I’m French with my rotten English. But also that I’m on these different problems for more than a week. I posted my problems in different french support but I have no response… So apologize me if I look completely desperate.

    To begin, I share with you the end part of my wp-config.php for multisite and my .htaccess, maybe that could help.

    wp-config.php

    /**
    MULTISITE*/
    define('WP_ALLOW_MULTISITE', true);
    
    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'www.thegreatpearler.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    /* C’est tout, ne touchez pas à ce qui suit ! */

    .htaccess

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    </IfModule>
    # END WordPress

    I will try to describe my problems as simply as possible.

    I recently installed a new website, multisite, subfolder, to create a completely dedicated shop: the URL is: https://www.thegreat.pearler.com/concept-store. This is the first time I install a website and I configure a multisite at the same time.

    1) Problem with plugin activation

    To begin, my first problem is that I can not activate a specific plugin on one or the other website. I am obliged to activate my plugins on the whole network whereas I am supposed to be able to activate plugins separately on one or the other website. I do not understand why. I do not have the option to activate a plugin, either on my main website or with my secondary website. I think it’s not normal …

    I share this error here because maybe the next error is related to the first one.

    2) HTTP error when uploading media or images

    The other big problem is that I can not upload media to my secondary website (but it works fine on my main website). I have a red box that appears with the code “HTTP error”. To solve this problem, I had to try a dozen different solutions:
    => Reduce or resize the file
    => Rename the image file
    => Temporarily disable plugins and theme
    => Increase the PHP memory limit
    => Check the permissions of the downloads folder
    => Switch to the latest version of PHP
    => Remove the custom path from the media library

    Nothing worked.

    I have explored the problem a little bit and tried things that I will try to explain. For starters, as I said, when I upload an image for example, I have an error “HTTP error” and the thumbnail of my image does not appear in the media library. But his name is clearly visible.

    But the file is well upload on the server … And accessible when following the path.

    This path is: www> wp-content> upload> sites> 4> 2019> 4. The access rights of the files are in 755 and the files are in 644, which seems correct.

    On the wordpress admin, I can “regenerate thumbnails” for all my “ghost” files, those whose name appears on my server and in the media library but whose thumbnail is invisible. And when I do that, oh miracle, the thumbnails of my images finally appear and I can finally use them in my different posts ….

    Completely strange and not at all practical, you will agree …

    I do not know at all which way to attack the problem and I leave it to you to help me to find a solution … It would be so great: D

    In the meantime, thank you for the time you will take to read me …

    Best regards (and especially if I can bring any additional information, tell me).

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘HELP – Multiple problems with configuring a multisite’ is closed to new replies.